PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
How to bleed coolant system on 2.0 PT Cruiser

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Nov 2010, 01:50 pm
Fresh Cruiser
 
Join Date: Nov 2010
Location: South Africa
Posts: 6
Default How to bleed coolant system on 2.0 PT Cruiser

Hi, I am new to this forum as I just recently became a PT owner.

The engine is running very hot - the temp guage goes all the way up to just below the red section, and I then shut it down to prevent damage. Although the cooolant expansion tank is at the correct level, the water level at the thermostat housing / pressure cap is non existant when I remove the cap. I have filled with water a number of times, and even opened up the bleed screw to get rid of air locks, but to no avail. I would put in 4 liters of water, run it till hot, and when I open the cap again is has no water in it. I must have put at least 8 liters of water into the system, it it seems to miraculously disappear.

No water in the oil, no excesive water / steam out the exhaust, no water leaks anywhere and the engine runs evenly.

Where could the water go - is there perhaps a very special way of getting rid of airlocks in the system/bleeding?
Reply With Quote
  #2 (permalink)  
Old 14 Nov 2010, 02:17 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: How to bleed coolant system on 2.0 PT Cruiser

Welcome to the Forum.

We here in the States do not have the 2.0 engine, but I would imagine that running the engine until hot and then using the bleed off screw would do the same as for our 2.4L engines.

The other thing is maybe one of the radiator fan speeds is no longer working. If you look under the Performance Section there is a Sticky: Removing the fan and housing 01-05 PT, it should tell you about how to check for the fan, ours is a two speed fan.

There is a couple of PT Clubs in the UK, they have the 2.0 and the diesel and may be able to help you.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #3 (permalink)  
Old 14 Nov 2010, 09:44 pm
Cool Cruiser
 
Join Date: Dec 2009
Posts: 301
Default Re: How to bleed coolant system on 2.0 PT Cruiser

Quote:
Originally Posted by xr3tf View Post
I must have put at least 8 liters of water into the system, it it seems to miraculously disappear.
No water in the oil, no excesive water / steam out the exhaust, no water leaks anywhere and the engine runs evenly.
Where could the water go?

I once owned a Saturn L100 that did the same thing.
The coolant would just disappear.
No leaks, no steam, nothing.
It turns out the L100's had very porous aluminum blocks and the coolant would dissipate slowly through the block without a trace.
Only way around was to keep adding coolant.
In my case I went through about 8 liters of mixed (50/50) coolant annually.
Lot cheaper then changing the block

Needless to say I did a lot of hunting on the internet to try and figure what was going on and I still have the pages bookmarked.
Here is an excerpt from one:

From the Saturn forum:
"GM for a while had issues with porous castings. A porous casting is where air is not evacuated from the metal poured in the casting. The tiny amounts of trapped air cause fluid leaks. It is sometimes referred to as metal or block porosity."


Maybe your PT has the same problem.
Please follow up and let us know your resolution.
Reply With Quote
  #4 (permalink)  
Old 15 Nov 2010, 02:22 pm
Fresh Cruiser
 
Join Date: Nov 2010
Location: South Africa
Posts: 6
Default Re: How to bleed coolant system on 2.0 PT Cruiser

8 liters per annum is a lot of coolant, but 8 litres in a matter of three days and less than 10 kilometers travelled?

Will advise what the problem & solution was, as soon as I find it
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant System Drain Plug Mansel Tech & Performance Forum 6 30 Aug 2015 04:34 pm
Coolant System Problem. PLEASE HELP!!!! cgrayflorida General PT Cruiser Discussions 2 24 Jul 2010 05:10 pm
Coolant sensor/fan system help please? swordfish Tech & Performance Forum 9 03 May 2010 09:30 pm
coolant leak, pressure in system RaceWilson Tech & Performance Forum 5 24 Feb 2010 08:07 am
How to Bleed thePower Steering System ptrican General PT Cruiser Discussions 1 17 Feb 2010 09:21 pm


All times are GMT -5. The time now is 07:07 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors