PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Rough idle and stutter under load - possible misfire.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Nov 2010, 03:17 pm
Fresh Cruiser
 
Join Date: Nov 2010
Posts: 1
Default Rough idle and stutter under load - possible misfire.

2000 2.0 Petrol PT - Suffering from stutter, and bad attitude under load. Problem solved with new ignition leads, plugs and a battery disconnect for 10 mins. From reading the forums the battery disconnect resets the ECU and the new leads seemed to solve the stutter. Parts used were Magnecor 8.5mm leads and Champion double platinum plugs from the PT Cruiser company - UK. Thanks to some of the posts on this site I was able to avoid some costly troubleshooting at the garages.

Does anyone have any opinions on Diagnostic tools (code readers) for the PT - do they help much with a troubleshoot with regard to saving on garage bills..?

Cheers
Reply With Quote
  #2 (permalink)  
Old 14 Nov 2010, 04:30 pm
chris15's Avatar
Senior Cruiser
 
Join Date: Jan 2008
Location: Tampa, Florida
Posts: 1,035
Default Re: Rough idle and stutter under load - possible misfire.

GENERALLY speaking, code readers aren't necessary as we can derive codes straight from the ECU with the 'key dance'. Not sure if the 2.0 models have this ability, but look it up and try it.
__________________
2003 GT (6262, the works)
2001 PT MTX-Swapped/Turbo

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle/Missing Under Load Etc. MattTee Tech & Performance Forum 9 03 Oct 2012 07:51 pm
Rough idle Jcamden Tech & Performance Forum 0 29 May 2010 02:56 pm
Rough Idle, Rough @60, check engine light NEW Dystroy Tech & Performance Forum 8 12 Jan 2009 09:07 pm
Hard Misfire Under Load plugs changed karterfred Tech & Performance Forum 11 10 Jan 2008 07:10 am
Rough idle PTPaul Tech & Performance Forum 1 17 Oct 2001 05:34 pm


All times are GMT -5. The time now is 02:50 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors