PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2007 p0303 code after changing plugs & wires

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 20 Nov 2010, 09:27 pm
Fresh Cruiser
 
Join Date: Nov 2010
Posts: 3
Default 2007 p0303 code after changing plugs & wires

I have a 2007 base model ptc. I recently had a p0303 code. Found out what it was & saw that the recommendation was to change the plugs & wires. After changing the plugs & wires, i reset the check engine light (removing negative battery cable). Started it up & ran real smooth. Drove it for approx. 15 minutes & while stopped at a stop light, the check engine light starts flashing. I had the ac on at this time. As soon as i start moving, the check engine light quits flashing & disappears. When i stop, i try to pull the code & there is none there. I then leave & the check engine light comes on again & stays lit. When i get to where I'm going, i check the code & it is a p0303 code again. Could it possibly be the coil pack? Don't know much about cars, but have learned alot on this site. Thanks for your help.
Reply With Quote
  #2 (permalink)  
Old 20 Nov 2010, 10:00 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2007 p0303 code after changing plugs & wires

The coil is divided into two for cylinders 1 & 4, 2 & 3. Your only getting the code for cylinder #3. You changed both the plugs and wires so you have to look for something else. A bad fuel injector, a burnt valve. How did the plugs look when you replaced them. Was cylinder 3 plug clean or burnt and did it have any oil on it?
Reply With Quote
  #3 (permalink)  
Old 20 Nov 2010, 10:17 pm
Fresh Cruiser
 
Join Date: Nov 2010
Posts: 3
Default Re: 2007 p0303 code after changing plugs & wires

# 3 looked no different than the others. They all looked like they had 70,000+ miles on them. No oil on any of them.
Reply With Quote
  #4 (permalink)  
Old 20 Nov 2010, 10:38 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2007 p0303 code after changing plugs & wires

Well, back to the injector or valve. You might want to have it checked out by a scanner to try and pinpoint the exact problem.

If the car is running OK, and your just getting the fault light, you might try the battery cable again.
Reply With Quote
  #5 (permalink)  
Old 21 Nov 2010, 12:54 pm
Banned
 
Join Date: Sep 2009
Location: south of Tampa, Florida
Posts: 3,037
Default Re: 2007 p0303 code after changing plugs & wires

If you had 303 before the plug/wire change and now that same code has came back you "probably" have an injector problem. Try running a can of good cleaner through a full tank or two of gas. I use a bottle of Chevron "techron" every six months "just because". I substituted Chryslers fuel system cleaner (in a bottle just like the "techron") once and it seemed to work just as well. I had to change the plugs out on a customers PT that had used the "lucas" fuel cleaner. By the time he brought it to me he had pretty well used the entire tank of gas and it had started to run rough. I pulled the plugs and they all had a build up on the plugs that wasn't there before. I had just changed them about three months before. I changed the plugs and we put in a bottle of "techron" and "bob's your uncle" everything was fine. I checked the plugs again two tanks later and the plugs were still clean as a whistle. In other words, not all cleaners are the same.

Something may not come to mind as you were reading the above statement is, if it did that to the plugs, then it would be leaveing those same deposits on the 02 sensors and the cat. I changed out the upstream and downstream sensors at the same time that I changed the plugs because they were an easy and inexpensive change. The cat didn't fall into that catagory, so we left it with our fingers crossed. The cat can be damaged by many differant
chemicals, like lead and even the zinc that was such an important part of the oil that we used to use in ALL of our motors in the "good ol days". You can still buy high performance oil that has zinc in it, but it states on the can that it's for racing/off road use only. In other words don't use it on a car with a cat (check my sig).

Like Crewzin said though, If you want to quickly find out exactlly what is causing the code, have it scanned and you'll know for sure.

Jerry
Reply With Quote
  #6 (permalink)  
Old 04 Dec 2010, 07:16 pm
Fresh Cruiser
 
Join Date: Nov 2010
Posts: 3
Default Re: 2007 p0303 code after changing plugs & wires

Have since changed the fuel injector. Still getting the same code. Bout ready to shoot it. Any ideas?
Reply With Quote
  #7 (permalink)  
Old 11 Jan 2011, 10:28 pm
Fresh Cruiser
 
Join Date: Jan 2011
Posts: 1
Default Re: 2007 p0303 code after changing plugs & wires

I have a 2006 PT Cruiser, and at 60,000 it started to idle very rough. I had the plug and wires replaced, coil replaced, with no solution to the problem. It turned out to be #3 cylinder had a burnt valve. Is this a common problem?
Reply With Quote
  #8 (permalink)  
Old 12 Jan 2011, 05:46 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2007 p0303 code after changing plugs & wires

Quote:
Originally Posted by kentfield1951 View Post
I have a 2006 PT Cruiser, and at 60,000 it started to idle very rough. I had the plug and wires replaced, coil replaced, with no solution to the problem. It turned out to be #3 cylinder had a burnt valve. Is this a common problem?
No, it's not common at all.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CHANGING SPARK PLUGS & WIRES?? mjb457 Tech & Performance Forum 10 21 Oct 2009 03:01 pm
P0301 Code even with new plugs and wires? ottoman Tech & Performance Forum 3 10 Feb 2009 09:07 am
Changing plugs/wires 2006 touring discovering06 Tech & Performance Forum 2 18 May 2008 06:02 pm
Changing plugs and wires vegasbob Stage Turbo Kits 3 29 Nov 2005 02:04 am
Procedure for changing wires and plugs? snakepitt1 Tech & Performance Forum 8 07 May 2004 09:18 am


All times are GMT -5. The time now is 07:41 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors