PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Radiator Fan and A/C problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 Dec 2010, 01:58 pm
Fresh Cruiser
 
Join Date: Oct 2010
Location: Suffolk County, Long Island
Posts: 18
Default Radiator Fan and A/C problem

I used to get a code for one of the fan relays; it went away by itself. I donít remember if it was the low or high, but did not look into it because I was not having a cooling problem. I know the fan used to kick on at times, I could feel it, and it would always come on when A/C or defroster was in use. The A/C worked the last time I used a few months ago.

Recently, I rear-ended a truck and took his trailer hitch into my grill. It hit just in the perfect spot that it broke the plastic side rail of the radiator where the A/C lines connect. Needless to say, I lost Freon and Coolant.

I replaced the radiator. Got everything back together; A/C lines connected (luckily no damage to them), original Fan re-used, filled with Mopar HOAT coolant.

Now the fan never comes on and the A/C compressor never engages. I am getting a code for the low speed fan circuit (1490 if I remember correctly).

I tried to charge the A/C system but donít believe it will ever suck the Freon in if the compressor never engages, correct?

I swapped the horn relay with the high speed fan relay and there was no change (horn does work). I installed a new low speed fan relay and there was no change.

Laying on the ground looking up at the bottom of the radiator with fan connection unplugged I jumped the pins to the battery. Connecting the left and middle pins did not turn on the fan. Connecting the middle and right pins did turn the fan on. Is that the high speed side?

Will the high speed ever kick on when there is an issue with the low speed?
Is there something related to the fan that would keep the A/C compressor from engaging?

Iím at a loss with no fan and no A/C compressor. Luckily itís cold now in the NorthEast and I donít need the A/C and under normal driving conditions donít need the fans to kick on.

Any ideas would be appreciated.
__________________
2001 PT Cruiser, Base Model, Dark Blue
NGK GP-Series Platinum Plugs, Autolite Wires
116k, Avg. 22+mpg mixed driving
Reply With Quote
  #2 (permalink)  
Old 08 Dec 2010, 03:14 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: Radiator Fan and A/C problem

but you do need defrost and I think that used the compressor
Reply With Quote
  #3 (permalink)  
Old 08 Dec 2010, 04:10 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Radiator Fan and A/C problem

The low speed and high speed parts of the fan will work independently. Sounds like you didn't have the low speed for a long time, before the crash. The compressor is a different matter. You can get the system filled properly without the compressor running. When a normal system looses the R134a for some reason the pressure switch will shut the system down (turn off the compressor). It can be filled up and the compressor will start again. The compressor has to checked out. The crash might have damaged it. You also want to have both speeds of the fan in working order. As Cruiserdad said, the defrost mode runs the compressor so you do need it in the winter time.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 09 Dec 2010, 12:20 pm
Fresh Cruiser
 
Join Date: Oct 2010
Location: Suffolk County, Long Island
Posts: 18
Default Re: Radiator Fan and A/C problem

So, does the defroster function kick on the low speed or high speed fan? Cause I'm pretty sure it used to work before the crash. Now, even when I turn on the A/C or defroster the fan does not come on. I'm thinking that if the compressor is not functional the fan won't come on either when using the defroster or A/C since the compressor operation is what triggers the fan to come on.

I ordered a replacement fan since I know one speed is definitey bad either way. I'll also try a fresh can of freon to charge the A/C system. The one I used was not full and quite old.

Thanks for the replies guys.
__________________
2001 PT Cruiser, Base Model, Dark Blue
NGK GP-Series Platinum Plugs, Autolite Wires
116k, Avg. 22+mpg mixed driving
Reply With Quote
  #5 (permalink)  
Old 09 Dec 2010, 01:18 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Radiator Fan and A/C problem

The defroster function, through the computer, kicks on the fan (not sure which speed) not the function itself. The computer has the whole responsibility of seeing the defroster come on, watching what temperature the coolant is, and by use of the relays, turns the fan on.

The high and low sides of the R134a system have to just right. You can throw in a can and hope for the best but without proper guages your just guessing. Some jobs are left to professionals.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radiator problem jpassons Tech & Performance Forum 4 16 Oct 2010 07:07 am
ODD RADIATOR FAN PROBLEM barryrobinette Tech & Performance Forum 5 25 Aug 2010 07:50 am
2001 radiator fan problem koor Tech & Performance Forum 14 23 Aug 2010 06:47 pm
Radiator fan problem moparman3 Turbo Performance 0 29 Oct 2009 08:23 am
Radiator 4b316 Tech & Performance Forum 3 26 Dec 2008 05:56 pm


All times are GMT -5. The time now is 12:35 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors