PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Battery Failure

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Dec 2003, 05:34 pm
Fresh Cruiser
 
Join Date: Dec 2003
Location: Nanoose Bay, British Columbia, Canada.
Posts: 3
Send a message via AIM to ptbcblues
Default Battery Failure

I have owned my car for almost 3 years. I loved it at first but I believe it's one of those proverbial lemons. Along with the A/C foul odor problem, not great gas mileage and various other problems I am now on the 4th battery. The car fries batteries and they've yet to determine what the problem is. All I ever hear is that it is shorting out the battery. If anyone has a similar problem I'd love to hear from you and what if anything can be done to fix it.
Thanks.
Reply With Quote
  #2 (permalink)  
Old 02 Dec 2003, 05:41 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

1) Find another place to look at the problem.
2) If you're paying for the batteries, get one (like a diehard) that has a warranty.

Haven't heard of others eating batteries - you don't have a "killer" sound system you added, do you?[:I]
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 02 Dec 2003, 06:11 pm
Fresh Cruiser
 
Join Date: Dec 2003
Location: Nanoose Bay, British Columbia, Canada.
Posts: 3
Send a message via AIM to ptbcblues
Default

Fortunately so far the car is still under warranty so I've not had to pay a penny yet... but the warranty is about to run out. The battery has been fried consistantly approx every 10 months. I don't want to have to continually pay for a new battery every 10 months or so.
And no I don't have a boosted sound system. Have the one it came with... which is awesome enough for me.
I think I will take up the advice on getting some other place run some diagnostics however.

Thanks.
Reply With Quote
  #4 (permalink)  
Old 02 Dec 2003, 06:38 pm
Young Cruiser
 
Join Date: Aug 2003
Location: The Woodlands, TX, USA.
Posts: 86
Default

Check to see if you have a "Lemon Law" and then use it!
__________________
<b><font color=\"red\">2003 LT ALMOND GT</b></font id=\"red\">

<font color=\"blue\">MODS:</font id=\"blue\">

Stage I, Custom Pin Stripe, Rear Spoiler, BTG Polished Strut Tower Brace, Borla 2.5\" CAT Back Dual Exhaust, and AirAid Intake System, Polished Front & Rear Sill Plates, Chrome Antenna Bezel w/10\" Chrome Billet Antenna, Mobil 1 and K&N Gold Filter, \"Flame\" 3rd Brake Light, \"Streamline Design\" PT Cruiser Visor, Rear Shelf Graphics and Dash Dots on Steering Wheel, and MGW \"GT\" Auto Shift Knob,Chrome Door Lock Pulls, Chrome Billet A/C Knobs with Acrylic Red Inserts, Chrome Oil Cap, Chrome Dip Stick, Chrome Radio Knob, Blane\'s Hood Lift Kit. Chrome Raidiator Coolant Bottle Cover, Timing Belt Housing Cover, Shock Tower Covers w/Nuts, Power Brake CYL Cap Cover, Windshield Washer Cap Cover, A/C Line Connector Cap Covers, A/C Check Valve Cap Covers and Radiator Cap Cover. \"GT2\" Rolo Red Calipers, Magnecor 8.5mm Spark Plug Wires - Red, Red Wire Looms, Billet Aluminum Steering Wheel Caps (4), Chrome Coin Tray Trim Cover, Chrome Shifter Bezel Tirm Ring, Yoko AVID V4S - 215/50/70\'s, TYC Euro Style Back-up Lights, and Screamin Demon Coil
Reply With Quote
  #5 (permalink)  
Old 02 Dec 2003, 06:54 pm
Dedicated Cruiser
 
Join Date: Oct 2003
Location: Jacksonville, NC, USA.
Posts: 2,612
Default

ptbcblues, you're not alone. Check out the links below, some good information and maybe a solution for your problem.

http://www.ptcruiserclub.org/cgi-loc...0dying;#123711

http://ptenthusiasts.org/PTForums/sh...t=dead+battery

http://ptenthusiasts.org/PTForums/sh...t=dead+battery

http://ptenthusiasts.org/PTForums/sh...t=dead+battery
__________________

2002 Inferno Red PT Limited
Photos and more at: http://www.randgraphics.org/PT_Cruiser/demos/index.htm
Mercedes Wiki
Reply With Quote
  #6 (permalink)  
Old 02 Dec 2003, 08:58 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default

ptbcblues:
I had a '02 T&C Van that I was driving when it went dead, luckly I was almost at the dealers.[xx(] They installed a new battery, the tech said, "We have had to replace quite a few of these, the manufacturer had a bad batch." Since then we haven't had a bit of trouble. We have been very pleased with the service we have gotten from them. It also is a 5 star!!! I read some of the suggested links, they have some good ideas there.[^]
Reply With Quote
  #7 (permalink)  
Old 03 Dec 2003, 08:47 am
Regular Cruiser
 
Join Date: Nov 2003
Location: Antelope Valley, Ca, USA.
Posts: 110
Default

This could be related to your problem, have your dealer check for this....

Recieved Customer Satisfaction Notice / Recall From DC #C30:

2003 & 2004 PT Cruisers and varoius other DC models.

The problem is....
The Powertrain Control Module (PCM) electrical connector seals on your vehicle may be out of place. This could allow water to enter the PCM. Water and resulting corrosion inside of the connector can cause various electrical and drivability concerns.

What DC and your dealer will do....
DC will repair your vehicle free of charge (parts and labor). To do this, your dealer will inspect the PCM electrical connector seals and repair any that are found to be out of place. If a connector is corroded, the PCM and affected wire harness will be replaced.
__________________
RD CHILI -- PHUN Time Cruisers Club
04 GT Inferno Red Loaded, Mopar Dual Exhaust, K&N Air Filter, Mopar Cabin Air Filter, Mopar BOV Kit, Blane Hood Struts, Strut Tower Brace, Kaiser Custom 17\" Wheels, Nankang Sport NS-1 225/45R17 Tires, Custom Decals, TYC Back-up Lights, LED Glow Lights in and out, Red Fuzzy Dice, Yet To Go; Mopar Stage-2 Turbo Kit, Mopar Stage-2 Suspension, Custom Paint.
Reply With Quote
  #8 (permalink)  
Old 03 Dec 2003, 03:48 pm
Fresh Cruiser
 
Join Date: Dec 2003
Location: Nanoose Bay, British Columbia, Canada.
Posts: 3
Send a message via AIM to ptbcblues
Default

Thanks for the excellent responses and the most excellent sites IRPT. Sounds like I'm definitely not alone out here. Unfortunately Canada does not have Lemon Laws, but I'm trying to see if we have anything close. There are Warranty Enforcement laws so maybe there is something there. The thing is I don't have a fight with the dealership, they've been super guys so far. It's just that I want to get to the root of the problem. What is shorting it out?

I've read some cases where people have battery drain problems and then the battery goes dead. My car doesn't sit long enough for a drain to happen. The longest my poor baby gets to rest is maybe 24 hours. (single mom with 2 daughters)...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PT Crusier battery dies after 5 days of no use. PT OWNER General Turbo Discussions 22 28 Jan 2009 11:51 am
Tried a battery search???? gonzomania General PT Cruiser Discussions 7 22 Feb 2007 12:31 pm
Battery Corrosion SteelBlueGT General Turbo Discussions 9 19 May 2005 06:47 pm
BATTERY SOURCE NEEDED clevelandmike General PT Cruiser Discussions 3 06 Oct 2004 09:54 am
Volume reduced when battery disconnected tom-t-rifik Sound and Security Forum 0 28 Jun 2004 05:25 pm


All times are GMT -5. The time now is 03:01 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors