PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Is my PT dead?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12 Dec 2010, 11:28 pm
Fresh Cruiser
 
Join Date: Dec 2010
Posts: 2
Default Is my PT dead?

I was driving in severe blizzard conditions yesterday in my 2006 cruiser.
Its got automatic transition and because of the severity of snowfall here in MN
I was forced to use gear 1 + 3 a lot. After barely getting my car into my garage I tried to start it today but there was nothing. My remote key wouldn't work and absolutely no lights came on. When I tried turning the enging there wasn't even a click.
Right before I turned off yesterday there was some smoke out of the passenger side of the hood too. At this point I'm hoping it's battery related. If it was the alternator belt would there still be some electricity?
Thanks for any help guys!

Last edited by Marco421; 12 Dec 2010 at 11:30 pm.
Reply With Quote
  #2 (permalink)  
Old 12 Dec 2010, 11:34 pm
SCBluePT's Avatar
Dedicated Cruiser
 
Join Date: Sep 2010
Location: Winnsboro,SC
Posts: 2,706
Default Re: Is my PT dead?

It sounds like it is battery related.I would charge the battery and go from there.If the alternator or belt is bad that would have caused your battery to go dead but you wont know until you charge the battery and run it.

Last edited by SCBluePT; 12 Dec 2010 at 11:37 pm.
Reply With Quote
  #3 (permalink)  
Old 13 Dec 2010, 12:12 am
Fresh Cruiser
 
Join Date: Dec 2010
Posts: 2
Default Re: Is my PT dead?

Thanks for your quick response! Could it be the power fuse (40W)?
Reply With Quote
  #4 (permalink)  
Old 13 Dec 2010, 12:53 pm
Fresh Cruiser
 
Join Date: Dec 2010
Posts: 32
Default Re: Is my PT dead?

Driving in heavy snow likes to force snow in between belts causing no friction with altenator, it is not uncommon to see that happen. Hopefully after a charge and things dry out you will be back behind the wheel.
Reply With Quote
  #5 (permalink)  
Old 13 Dec 2010, 09:34 pm
Matt42's Avatar
Cool Cruiser
 
Join Date: Jun 2009
Location: Glendale, AZ
Posts: 496
Default Re: Is my PT dead?

I love Arizona.
__________________
1996 Dodge diesel 4X4, 2001 PT Cruiser Touring with rear disc brakes, [Now gone 2004 PT Cruiser Base 5 speed], 2007 Chrysler T&C Touring
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
dead car klondikeone Tech & Performance Forum 4 09 Nov 2010 02:02 am
Dead PT need help benjibbad General PT Cruiser Discussions 7 26 Mar 2010 03:10 pm
PT Dead - Need Help! silver7 Tech & Performance Forum 14 08 Mar 2010 11:50 am
Pt dead Maineiac General PT Cruiser Discussions 5 21 Jul 2009 10:05 am


All times are GMT -5. The time now is 06:34 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors