PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
clutch issue

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Feb 2011, 10:18 am
Fresh Cruiser
 
Join Date: Mar 2010
Posts: 8
Default clutch issue

A couple days ago I noticed things didn't feel right and since the roads were icy I reasoned it was the tires slipping a little. Well over the next couple days the roads improved yet the problem persisted.

It felt like the clutch was staying engaged after releasing and I would have to rev the motor a little higher to get it to go and eventually it would go and I could drive. Well, yesterday on my way home from work it progressively got worse to the point where it stays engaged and I can shift all gears smoothly without pressing the clutch in.

So, is this an issue that is possibly just master/slave cylinder issues or is it definitely a whole new clutch issue? or a possible combination of the two?
Reply With Quote
  #2 (permalink)  
Old 11 Feb 2011, 10:35 am
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: clutch issue

well its kind of liek this to do a slave cylinder I think yu have to seperate the motor and the tranny so why would you not just do the cluch at that time btu other who know way more will chime in
Reply With Quote
  #3 (permalink)  
Old 22 Feb 2011, 10:20 am
Fresh Cruiser
 
Join Date: Mar 2010
Posts: 8
Default Re: clutch issue

Just a bump to see if there are any other opinions out there.

Otherwise I will probably just buy master/slave cylinders and if that doesn't work buy a new clutch kit and be done with it.

I believe I have access to both master and slave cylinders without removing transmission. If removal of the transmission is required then I'll replace everything and be done with it.
Reply With Quote
  #4 (permalink)  
Old 22 Feb 2011, 10:35 am
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: clutch issue

Doesn't make sense, its hard for a hydraulic mechanism to hold something open
without mechanical assistance. I have zero experience with this, however.

I'd suggest removing / draining the slave, then seeing if clutch is still slipping.

I recall some problems with one series of PT self adjusting clutch, anyone
have further info?
Reply With Quote
  #5 (permalink)  
Old 19 Apr 2011, 02:02 pm
Fresh Cruiser
 
Join Date: Mar 2010
Posts: 8
Default Re: clutch issue

OK so I pulled the clutch out and it was thrashed.

Installing the new clutch went smoothly and ended up replacing my master and slave cylinder and of course, fluid. So essentially, I have a brand new clutch system.

The pedal feels softer now and only gears 1, 4, and 5 work normally. Gears 2 and 3 work but it grinds hard getting in them with the exception being if I am slowing to an almost stop it goes into 2nd freely.

What could cause this? Would air bubble cause this possibly?
Reply With Quote
  #6 (permalink)  
Old 19 Apr 2011, 04:53 pm
chris15's Avatar
Senior Cruiser
 
Join Date: Jan 2008
Location: Tampa, Florida
Posts: 1,035
Default Re: clutch issue

Sounds like a shifter cable issue, imo.

Check your adjustments and bushings inside the car, and also check your bushings on the trans as well.
__________________
2003 GT (6262, the works)
2001 PT MTX-Swapped/Turbo

Reply With Quote
  #7 (permalink)  
Old 20 Apr 2011, 09:55 am
Cool Cruiser
 
Join Date: Sep 2009
Location: Formerly NawLins
Posts: 246
Default Re: clutch issue

Sounds like a similar issue to what thejenius77 was having when she got her cruiser back from the guy that "stole" it. She fixed it, and since you had the tranny out it is possibly the same issue. Here is the thread:
Clutch, Tranny or something else??? PLEASE HELP!
__________________

12 Regal Turbo
06 PT - Base with BLING! TRADED 5/27/13
01 PT LE - Kid's Car - TRADED 01/13
01 Beetle Sport - SilverSport - 150+ MPH
93 Del Sol - 32+ MPG
90 F150
73 Mach1
Reply With Quote
  #8 (permalink)  
Old 20 Apr 2011, 05:17 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: clutch issue

I sell them but it'd be easier to go directly to Jeff unless you live in Minneapolis.

Boogerracing.com or something
Reply With Quote
  #9 (permalink)  
Old 21 Apr 2011, 12:37 am
Cool Cruiser
 
Join Date: Sep 2009
Location: Formerly NawLins
Posts: 246
Default Re: clutch issue

Quote:
Originally Posted by UptownSport View Post
I sell them but it'd be easier to go directly to Jeff unless you live in Minneapolis.

Boogerracing.com or something
Thanks

Ordered. Now to find a better engine mount for the 06.
__________________

12 Regal Turbo
06 PT - Base with BLING! TRADED 5/27/13
01 PT LE - Kid's Car - TRADED 01/13
01 Beetle Sport - SilverSport - 150+ MPH
93 Del Sol - 32+ MPG
90 F150
73 Mach1
Reply With Quote
  #10 (permalink)  
Old 29 Apr 2011, 10:35 am
Fresh Cruiser
 
Join Date: Mar 2010
Posts: 8
Default Re: clutch issue

Quote:
Originally Posted by SilverSport View Post
Sounds like a similar issue to what thejenius77 was having when she got her cruiser back from the guy that "stole" it. She fixed it, and since you had the tranny out it is possibly the same issue. Here is the thread:
Clutch, Tranny or something else??? PLEASE HELP!
Thanks for the link. I will open it back up and check the bushings. If I have any doubts at all I will just replace them with the booger bushings.

Thanks, I will let you all know what I find.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch ptbruiser2009 Turbo Performance 5 04 Oct 2009 09:23 pm
Clutch for GT onefastcruiser General Turbo Discussions 2 27 Apr 2009 03:58 pm
01 Clutch oddity-possible clutch master cylinder? opelenvy Tech & Performance Forum 6 17 Sep 2008 03:35 pm
GT 5 speed clutch noise or " clutch chatter". boosta General Turbo Discussions 3 11 Aug 2003 08:10 pm


All times are GMT -5. The time now is 04:27 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors