PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
another code P0340 thread

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Feb 2011, 12:35 pm
fabreezai's Avatar
Fanatic Cruiser
 
Join Date: Jan 2011
Location: Norad Colorado
Posts: 714
Default another code P0340 thread

Hi Guys-

Just wanted your opinion on this. Although I have read just about all the threads on this code, I'm not entirely convinced. Was driving the car yesterday, buzzing right along. The check engine light came on and about 10 seconds later the car would not rev past 2500 rpm, like it was starving for fuel or the timing was retarding. I got the car home, hooked my fuel pressure gauge to the rail and pumped up to 55-60 lbs, retested again then would not pump up past 10-15 lbs, retested several times, same thing 10-15lbs. Let the car sit for a bit, tested again 55-60 lbs. To the best of my knowledge has never had the fuel pump module/filter changed. Could it be a combination of both the cam sensor and fuel filter? or just one of the two? Any advice would be great!

Thanks in advance.

2003, touring edition, 121k, 3rd owner.
Reply With Quote
  #2 (permalink)  
Old 16 Feb 2011, 08:43 pm
Fresh Cruiser
 
Join Date: Oct 2008
Posts: 26
Default Re: another code P0340 thread

I have had code in past (a couple times) and changed sensor to resolve. Unplugged battery to clear, resolved the safety (puts into 2nd and will not go much above 45 mph) but came back later. Did change sensor one time with supply store part-it went out 35 days later-had to get another. 140K and still doing well-has become a hand me down car for kids. Last issue was gas cap code and finally had to put on a new one to resolve code repeating. Good luck, this is a great site for info/help. Biggest issue with car has been timing belt replacement and the front end parts-goes through them but is a design issue discussed in other threads I think.
Reply With Quote
  #3 (permalink)  
Old 16 Feb 2011, 09:56 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: another code P0340 thread

The fuel filter is part of the fuel pump and is not meant to be changed. The pump can go bad if you've let the tank get really low a few times. The fuel cools and lubricates the pump and letting the tank go low a couple time can burn the pump out.

The P0340 code could be either the Cam shaft sensor or the wiring harness that attaches the sensor to the computer. A couple of us have had the harness rub against something that would damage the wires.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 17 Feb 2011, 02:27 pm
fabreezai's Avatar
Fanatic Cruiser
 
Join Date: Jan 2011
Location: Norad Colorado
Posts: 714
Default Re: another code P0340 thread

Has anyone experimented with a external fuel filter set up? if so what were the results? Don't know how many times the fuel tank has been run low. I believe we are the 3rd owner. I'll check the wiring going to the sensor for any damage and re-post. thanks for the replies.
Reply With Quote
  #5 (permalink)  
Old 17 Feb 2011, 05:49 pm
fabreezai's Avatar
Fanatic Cruiser
 
Join Date: Jan 2011
Location: Norad Colorado
Posts: 714
Default Re: another code P0340 thread

Checked wiring to sensor, no obvious damage or rubbing. Cleared code and runs ok for now. Because I cant find any info on the car as to the timing belt ever being changed (has 121k on it) is there any known way to inspect it or is it just change it along with the water pump & tensioner for peace of mind? (being that it's a pain to change, I'm happy to do so if necessary) as well would you recommend changing the fuel pump/filter module with the mileage?

thanks again for any replies.
Reply With Quote
  #6 (permalink)  
Old 17 Feb 2011, 05:55 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: another code P0340 thread

I dont knwo any way to check the belt so as big a pain as it is I go ahead and change the belt tensioner and water pump maybe theromstat and the hoses btu then you sart getting into to where do you stop I would do the fule pump dont think i have heard of anybodys going out btu im sure it happens
Reply With Quote
  #7 (permalink)  
Old 17 Feb 2011, 05:57 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: another code P0340 thread

Fuel pump and filter are lifetime (I believe). Only person I ever heard of that changed it was when he was having trouble and put a pressure test on the fuel line.

The belt could look good and be ready to come apart. Don't think there's sure way to tell if it's new and very used. I could be wrong. If you bought the car right before the 100,000 mile mark, it's a good bet someone traded it in before that put the money out to have it changed.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #8 (permalink)  
Old 17 Feb 2011, 06:47 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: another code P0340 thread

+2 that would be my thought, dump it b 4 it turns into a $$$$$ pit!!! Change the belt, pump & tensioner.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #9 (permalink)  
Old 18 Feb 2011, 04:48 pm
fabreezai's Avatar
Fanatic Cruiser
 
Join Date: Jan 2011
Location: Norad Colorado
Posts: 714
Default Re: another code P0340 thread

We just purchased the car from our daughter with 121k on it, she had it for just over a year and purchased it with 116k. We went on a 150 mile trip today and the car set the p0340 code 2 times, and reset itself both times. While I was in town, I stopped by the Chrysler dealer and picked up a new sensor (per you guy's recommendation). Have not installed it as of yet. I will repost as soon as I do. Have a few few things to do to it this weekend, tires, brakes, rotors, windshield repair, K&N air filter. All, mostly for peace of mind.
Reply With Quote
  #10 (permalink)  
Old 18 Feb 2011, 07:30 pm
WolfmanG's Avatar
Veteran Cruiser
 
Join Date: Nov 2010
Location: San Antonio
Posts: 4,495
Send a message via Yahoo to WolfmanG
Default Re: another code P0340 thread

i had that code come up. i disconnected the battery and it was fine. a week and half later it happened again. i disconnected the batter and it was fine. But this time i went to the dealer, forked over 60 bux and got a new cam shaft position sensor. after i installed it, i haven't had a problem since. so i suggest replacing it with a FACTORY replacement only to make sure this doesn't happen again. There's been a few ppl on the forum that have said that it's left them stranded.
__________________
-Danny Wolfman G
http://www.facebook.com/WolfmanG
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Touring PT with P0340 code jessilwow12 Tech & Performance Forum 8 09 Jun 2015 12:05 pm
P0340 Code. BlackJack Tech & Performance Forum 10 01 Mar 2010 09:26 pm
Error code P0340 ADVICE??? mjb457 Tech & Performance Forum 10 20 Aug 2009 09:24 pm
Code p0340 tommyis3 General Turbo Discussions 3 16 May 2009 01:51 pm
code p0340 sflamedic General PT Cruiser Discussions 5 21 Oct 2008 06:12 am


All times are GMT -5. The time now is 12:27 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors