PT Cruiser Forum  
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Sunroof not working.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 Feb 2011, 09:19 pm
Fresh Cruiser
 
Join Date: Feb 2011
Posts: 5
Default Sunroof not working.

Hi everyone,
I have a 2002 cruiser and the sunroof stopped working. No noise, nothing. If it does have a blown fuse, where would it be? Could it be the fuse, or something else. Pushing the bottons doesn't do anything, no noise or nothing. One other problem, my fog lights stopped working also. I have the green indicator that comes on in the instrument cluster but no lights. I have read it could be the multi funcution switch.
Thank you ahead of time.
George
Reply With Quote
  #2 (permalink)  
Old 26 Feb 2011, 09:26 pm
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 23,087
Default Re: Sunroof not working.

George, welcome to the forum.

Do you know you have a fuse panel by your left knee while sitting in the driver seat? If you pull off the panel cover and read what the fuses are for on the back of that panel, you'll see that the No#14 fuse is for the sunroof and the No #8 fuse is for the fog lights.

If it's not the No#8 fuse for the fog lamps, yes it could be the multi-function switch on the steering column. A very common fault.
__________________
......
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 117,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Visit My Home Page www.CREWZIN.com
NY Times article: http://www.nytimes.com/2008/10/30/au...30vintage.html
Reply With Quote
  #3 (permalink)  
Old 26 Feb 2011, 09:47 pm
Fresh Cruiser
 
Join Date: Feb 2011
Posts: 5
Default Re: Sunroof not working.

Ok well thank you so much. I have pulled the fuse box cover off many times, but didnt pay attention. Thank you very much, I will let you know what happens.
Reply With Quote
  #4 (permalink)  
Old 03 Mar 2011, 09:03 pm
Fresh Cruiser
 
Join Date: Feb 2011
Posts: 5
Default Re: Sunroof not working.

Sorry for the long time to post. I checked the fuses and there isn't any blown. My other question would be could the overhead counsol switch be bad, or a wire/ wire's be disconnected? Like I said before, when I push the switches (sunroof) nothing happens, not even a sound. And as far as the fog lights, the indicator in my dash still lights up green but no fog lights. After reading other posts I do belive I might have a faulty multi function switch.
Oh and I love my 2002 PT!! Thanks for the forum also.
George
Reply With Quote
  #5 (permalink)  
Old 04 Mar 2011, 01:39 am
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,524
Default Re: Sunroof not working.

If your green indicator light comes on when you flick on your foglamp, I would suspect that your bulbs might be out? I'd take a multimeter and measure voltage coming out to the lamp.

Reason I say this is because my multifunction switch is out as well, but when I turn on my foglamps my indicator light does not come on.

Could be wrong but just a thought.
__________________
My Toy


Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!
Reply With Quote
  #6 (permalink)  
Old 04 Mar 2011, 09:20 pm
Fresh Cruiser
 
Join Date: Feb 2011
Posts: 5
Default Re: Sunroof not working.

Thank you once again.
I'm going to check my lights and maybe they are blown out. I will have to do it either Sunday or Monday when I'm off. Any ideas where I could start as far as my sunroof goes?
Thank you all to a wonderful forum.
George
Reply With Quote
  #7 (permalink)  
Old 07 Mar 2011, 09:38 pm
Fresh Cruiser
 
Join Date: Feb 2011
Posts: 5
Default Re: Sunroof not working.

Hi everyone,
Well I found out the problems with my fog lights and sunroof. They weren't hooked up. My fog lights are working now and well my sunroof is also working BUT! It will open on vent, but when I go to open the sunroof it opens about a 1/4 inch then stops. It seems like it is being blocked, or stuck. Any ideas?
Thank you
George
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
sunroof help neon95 General PT Cruiser Discussions 2 19 Mar 2009 01:12 pm
sunroof neon95 General PT Cruiser Discussions 0 16 Dec 2008 07:50 pm
Sunroof blondecowgirl Interior Accessories Forum 3 21 Jun 2007 02:14 pm
sunroof HELP!!!!!!!!!! Lana Interior Accessories Forum 4 25 Sep 2006 04:38 pm
Air Dam for Sunroof hugh_mack General PT Cruiser Discussions 1 22 Nov 2002 07:38 pm


All times are GMT -5. The time now is 09:29 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors