PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
A/C, Low-speed fan not kicking on....

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24 Mar 2011, 02:01 am
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,574
Default A/C, Low-speed fan not kicking on....

Ok so I've read enough threads to see that our fans and/or relays commonly go out.

Anyway, I know enough what to check out but it's constantly raining and I don't have a garage to perform any troubleshooting. Just need to wait the weather out. In the meantime.....

Long story short about my AC/fan, about 5-6 weeks ago my friend said his PT Cruiser is running hot. Told him to turn on his A/C and his fan should automatically kick in like mine did (keep in mind the fan did kick in and A/C came on cold).

Well just today, I turned on the A/C as my normal ritual of making sure everything's working correctly and my fan didn't come on. A/C was warm.

Yes, the fan works because if I leave the engine on long enough my car goes through it's cycle of the radiator fan coming on then shutting off. What I'll be doing is testing the relays by swapping the high and low speed relays and turning on the A/C again.

My question is, if I'm low on freon...can this be the reason why my fan won't come on? I'd believe this to be true since the A/C isn't chilly/cold but wasn't sure if the fan should come on at all or not.

Like I said, when the weather clears I'll swap relays in case the low-speed relay went bad. If my freon levels are indeed low and the cause of my low-speed fan not coming on then I'll just get it recharged. If the freon-level has nothing to do with it then I'll assume it's the low-speed on the fan itself and just replace the fan.
__________________
My Toy


Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!
Reply With Quote
  #2 (permalink)  
Old 24 Mar 2011, 05:24 am
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: A/C, Low-speed fan not kicking on....

Low freon will cause the A/C fan NOT to come on.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #3 (permalink)  
Old 24 Mar 2011, 07:09 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: A/C, Low-speed fan not kicking on....

Agree with Hooligan. The R134a level is monitored by a switch and if pressure is low, the compressor won't come on and if that won't come on, either will the fan. Second, you can't swap relays. You can swap the high speed relay (F) with the horn relay (A) to see if it's good but the low speed relay is a size all it's own. There IS a spare relay (J) that's the same size as the low speed, maybe that can be swapped.

Reply With Quote
  #4 (permalink)  
Old 24 Mar 2011, 10:11 am
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,574
Default Re: A/C, Low-speed fan not kicking on....

Thanks guys.

And thanks Crewzin for clearing that up. Haven't been able to pop the hood so I wasn't sure if the statement about the high/low speed relays was true. Read it in another thread before posting this one.
__________________
My Toy


Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!
Reply With Quote
  #5 (permalink)  
Old 24 Mar 2011, 10:36 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: A/C, Low-speed fan not kicking on....

Quote:
Originally Posted by Kawizx9r View Post
Haven't been able to pop the hood so I wasn't sure if the statement about the high/low speed relays was true.

YOU DOUBT MY WORD ???
.
.
.
.
.
.
Only Kidding. I'd take anything I say as suspicious.
Reply With Quote
  #6 (permalink)  
Old 24 Mar 2011, 03:09 pm
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,574
Default Re: A/C, Low-speed fan not kicking on....

Quote:
Originally Posted by CREWZIN View Post
YOU DOUBT MY WORD ???
.
.
.
.
.
.
Only Kidding. I'd take anything I say as suspicious.
LOL

Should've rephrased. I meant this statement:

Quote:
Originally Posted by big block bob
If not, then you need to see if the low speed fan relay has failed. You can swap out with the high speed relay and test your low speed circuit.....
I got my eye on you though

What's with the 'spare' relay though? Chrysler just threw an extra one in there for a 'just in case I need it' moment?
__________________
My Toy


Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!

Last edited by Kawizx9r; 24 Mar 2011 at 04:25 pm.
Reply With Quote
  #7 (permalink)  
Old 24 Mar 2011, 03:47 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: A/C, Low-speed fan not kicking on....

You got me. Just like the spare fuses. Maybe the engineers that designed the PDC (Power Distribution Center) through that we might need some spares.
Reply With Quote
  #8 (permalink)  
Old 27 Mar 2011, 01:52 pm
Fresh Cruiser
 
Join Date: Mar 2011
Posts: 8
Default Re: A/C, Low-speed fan not kicking on....

I've been reading through the forums, and I appreciate the advice. I've replaced the low speed fan relay, but that hasn't helped with the problem. What is the next step?

Thanks in advance.
Reply With Quote
  #9 (permalink)  
Old 27 Mar 2011, 02:10 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: A/C, Low-speed fan not kicking on....

Quote:
Originally Posted by bluecruiserTX View Post
I've been reading through the forums, and I appreciate the advice. I've replaced the low speed fan relay, but that hasn't helped with the problem. What is the next step?

Thanks in advance.
It would nice is you told us what the problem is and introduce yourself. What car do your have, what's the mileage, and what have you done so far except read the forum. Why did you replace the low speed relay?
Reply With Quote
  #10 (permalink)  
Old 27 Mar 2011, 02:51 pm
Fresh Cruiser
 
Join Date: Mar 2011
Posts: 8
Default Re: A/C, Low-speed fan not kicking on....

Sorry, It's 2005 Touring Editon with about 80K on it. We bought it used 4 years ago with 37K on the odometer.

The AC cuts out when the car idles and then stutters when the compressor tries to kick on. Then it blows hot air untill the car starts moving again.

I don't seen any fan blades turning on the radiator fan, but then I can't see much of anything at all of the radiator fan....

In any event, the fan does not appear to be turning, and the low side port of the AC seems to be down near the compressor, where you can't get to it to without removing the grill and assorted bits. I would like to check the 134 level, but can't get to it. Dagnabit!

So, based on the great advice I've read about on the forum, I thought I'd start with the relay since that is only $12.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
More Speed rreyan General Turbo Discussions 30 31 May 2009 03:37 pm
Trac control kicking off E brake alarm? sknight88 General Turbo Discussions 1 05 Jul 2008 08:03 pm
5 speed 0-60 1quickpt General Turbo Discussions 17 19 Aug 2004 02:57 am
Is the 4 Speed A/S realy a six speed? Ian-PT-GT General Turbo Discussions 11 16 Apr 2004 10:19 pm
top speed skeeter1620 General Turbo Discussions 10 11 Jan 2004 03:20 pm


All times are GMT -5. The time now is 02:15 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors