PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Codes?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Apr 2011, 09:08 pm
BladeRunner's Avatar
Cool Cruiser
 
Join Date: Nov 2010
Location: Innisfil Ontario Canada
Posts: 372
Default Codes?

For the first time since I got my PT back in Oct..well once before ( just a loose gas cap) I have some codes. They were P1604..I think, and 0445. I'm really tired right now..long day, don't ask! I already erased them
Anyway, on my way home after work I only went 3 blocks and got the two codes.
When I got home I put the scanner on it and it said "evaporative system leak detected, cross flow..no flow".
What the heck does THAT mean??
It runs fine, so I hope I didn't hurt anything?
BTW, it's an '01 LTD N/A auto 214,000km.
Reply With Quote
  #2 (permalink)  
Old 11 Apr 2011, 09:30 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Codes?

The loose gas cap can trigger a code between 0442 and 0445 so hopefully thats the problem.

A more serious problem is the other code. Found what it is but not what to do about it;

P1604 PCM Internal Dual Port Ram Read/Write Integrity Failure - Dual port RAM read/write error.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 12 Apr 2011, 04:34 am
BladeRunner's Avatar
Cool Cruiser
 
Join Date: Nov 2010
Location: Innisfil Ontario Canada
Posts: 372
Default Re: Codes?

Thanks CREWZIN, the gas cap was the first thing I checked.
Reply With Quote
  #4 (permalink)  
Old 12 Apr 2011, 07:38 am
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Codes?

RAM read/write error is when your PCM needs a reboot to clean out it's internal cache. Need to disconnect your battery for at minimum 5 minutes, personally I'd give it 20. While it's disconnected, press on your brake a few times to bleed off any residual power. Should clear the code once you reconnect.
Reply With Quote
  #5 (permalink)  
Old 12 Apr 2011, 10:07 pm
BladeRunner's Avatar
Cool Cruiser
 
Join Date: Nov 2010
Location: Innisfil Ontario Canada
Posts: 372
Default Re: Codes?

Thanks Chromenut, I have a scan tool, I erased the codes last night and this morning on my way to work they didn't show up,but, tonight on my way home they came back.
I got the #'s wrong last night; 1684 is one & P0455 is the other one when I did the "key dance". When I hook up the scan tool tonight it only shows the P0455 code. I erased it again, I did check my gas cap. The first time the scanner read the code it said it was "evap system gross leak...no cross flow" ..Or something close to that,sorry..I've just worked 30 hrs since yesterday morning..having a MAJOR brain freeze Thanks for the info...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
TOO MANY CODES!!! Nonie Tech & Performance Forum 13 20 Mar 2011 12:21 am
obd-II codes Punch General Turbo Discussions 13 06 Jul 2009 06:54 pm
No Codes?? BB General PT Cruiser Discussions 2 13 Aug 2005 08:25 pm
obd codes camarillogolfer General Turbo Discussions 5 06 Aug 2004 11:10 am


All times are GMT -5. The time now is 02:27 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors