PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Another pt with a/c problems

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21 Apr 2011, 02:51 pm
Fresh Cruiser
 
Join Date: Oct 2009
Posts: 4
Default Another pt with a/c problems

so ti seems that a lot of people are having trouble with the a/c on their pt's. i did what many of the thread responses said, which was to check my fan. turns out the fan was not working properly, i replaced the dam expensive part and it works now the car doesn't shake anymore, although the a/c doesn't cool still. i think i can feel the compressor coming on, i re-charged it with freon, and it still doesn't cool. how much psi should it have maybe i added to much or not enough. has anyone had this problem please help
Reply With Quote
  #2 (permalink)  
Old 21 Apr 2011, 03:46 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Another pt with a/c problems

Yep, you probably don't have the right charge in it. If that's not right, the A/C won't work properly. I don't have the correct pressures to give you, hopefully someone will come along with that answer. As far as changing the fan out for a "dam" expensive one. Most of us use eBay for a new fan for under $100. You probably got your from a dealer.
Reply With Quote
  #3 (permalink)  
Old 21 Apr 2011, 04:44 pm
Fresh Cruiser
 
Join Date: Oct 2010
Posts: 46
Default Re: Another pt with a/c problems

I purchased the freon at Autozone that comes with a reusable recharge hose with in-line low-pressure gauge and range Finder.... $30 for 17oz.
Reply With Quote
  #4 (permalink)  
Old 21 Apr 2011, 05:13 pm
Fresh Cruiser
 
Join Date: Oct 2009
Posts: 4
Default Re: Another pt with a/c problems

just got back from getting my a/c checked add they told me that they couldn't get to compressor to come on, it wasn't getting any power. they check my fuse and the relay it was all good but the compressor was still not getting any power to it, i just change the fan recently because it had gone out and it wasn't blowing any cold air, now that i replaced the fan turns out that its still not blowing cold air because the compressor is not coming on, does anyone have any ideas as to why that might be.


thanks for your help and time to all those that take the time to read this.
Reply With Quote
  #5 (permalink)  
Old 21 Apr 2011, 05:50 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Another pt with a/c problems

Here's a couple links to check out:

How to Test the AC Relay in a PT Cruiser | eHow.com

No power supply is reached the aircon compressor. i just need the...
Reply With Quote
  #6 (permalink)  
Old 21 Apr 2011, 10:14 pm
Cool Cruiser
 
Join Date: Sep 2009
Location: Formerly NawLins
Posts: 246
Default Re: Another pt with a/c problems

Well ... if the pressure switch is bad ... you will not get power to the clutch. That is how the on off cycling is controlled that other threads are talking about.

There are a lot of places it could be, the dash switch is one also. The AC systems are very different between the 01-05 and 06-10 .... can't help much without that basic info, I'm no A/C expert but that would help one help you.
__________________

12 Regal Turbo
06 PT - Base with BLING! TRADED 5/27/13
01 PT LE - Kid's Car - TRADED 01/13
01 Beetle Sport - SilverSport - 150+ MPH
93 Del Sol - 32+ MPG
90 F150
73 Mach1
Reply With Quote
  #7 (permalink)  
Old 22 Apr 2011, 01:22 am
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: Another pt with a/c problems

When my A/C started bloing warm air at idle, and the engine would act like it was going to die (at idle with the A/C on), the problem was the radiator fan, as it has been with many of us who have had the same symptoms. But while I was checking to see if my fan blades were spinning (and I found they weren't--neither low or high speed), I just happened to look under the A/C compressor and saw some fluid coming from one of the A/C lines.

As it turned out, since my radiator fan wasn't cooling the high side of my A/C for quite a while, the pressure got so great in the compressor line that it slightly ruptured. Just enough to start a leak--not a whole lot, mind you.

So I wonder if the same event--or a similar one--happened to you. It would be logical to assume that super high "high pressure" on the compressor might cause some damage, either to a hose, or the compressor itself.

Tim
Reply With Quote
  #8 (permalink)  
Old 17 May 2011, 06:13 pm
Fresh Cruiser
 
Join Date: May 2011
Posts: 2
Default Re: Another pt with a/c problems

So I am also having problems with my PT Cruiser's AC and want to make sure I am understanding what I am reading. My radiator fan should kick on when I turn the AC on. I have been reading the sites and have checked that the compressor kicks one and the lines get cold but when at a traffic light blows cold air and when it is really hot outside it is hot as well. My radiator fan kicks on when the thermostat gets hot enough but not when I turn the AC on is this normal or do I need a new fan?

Thanks for all your help.

Scott
Reply With Quote
  #9 (permalink)  
Old 18 May 2011, 01:18 am
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: Another pt with a/c problems

Scott, you seem to say that at a traffic light it blows cold air and when it is really hot, warm air as well. So which is it? Cold or hot air blowing from your vents when at a traffic light?

If, after the car engine is nice and hot, and you turn on the A/C, the high speed fan should come on when at idle. It is a very noticeable whirring sound that is far more noticeable than the low spped fan noise (which I can't hear at all, to be honest).

If your high speed fan doesn't come on under the above stated conditions, it is often worn brushes on the high speed of the fan. In other words, your fan probably needs replacement. That's not an absolute ... but more often than not, it seems to be the case in our PT's--under the conditions mentioned.

Tim
Reply With Quote
  #10 (permalink)  
Old 18 May 2011, 11:53 am
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Another pt with a/c problems

Quote:
Originally Posted by Garrambide View Post
just got back from getting my a/c checked add they told me that they couldn't get to compressor to come on, it wasn't getting any power. they check my fuse and the relay it was all good but the compressor was still not getting any power to it, i just change the fan recently because it had gone out and it wasn't blowing any cold air, now that i replaced the fan turns out that its still not blowing cold air because the compressor is not coming on, does anyone have any ideas as to why that might be.


thanks for your help and time to all those that take the time to read this.
If they tested properly, they should have told you if the relay was functional. Telling you there's no power to the compressor can indicate a blown fuse or bad relay, and I'm surprised they didn't verify the relay as it takes about 1 minute to do so.

I would read the links that Crewzin posted and verify that before going the next step.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
a/c problems ape_stein Tech & Performance Forum 10 11 Aug 2010 10:29 pm
IOD Problems?? loneleix General PT Cruiser Discussions 4 21 Jun 2010 01:50 am
new guy here with problems tillerDave General PT Cruiser Discussions 2 13 Jun 2010 02:02 pm
PT problems AquamarinePT Tech & Performance Forum 9 09 Jul 2009 07:51 pm
'06 PT...Known problems? sifu_scott Tech & Performance Forum 2 19 Aug 2007 11:41 pm


All times are GMT -5. The time now is 10:12 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors