PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
PT Hose Problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06 May 2011, 04:40 pm
pug pug is offline
Fresh Cruiser
 
Join Date: May 2011
Posts: 1
Default PT Hose Problem

I have a 2002 pt cruiser, and i am having a problem with the coolant bottle hose. There are two hoses coming out of the bottle; on on the top right and one on the bottom left. The upper right hose has come off of wherever it is meant to be and when i pour coolant into the bottle it pours out of that hose onto the ground. My problem is i have no idea where the hose is supposed to connect to, and i cannot find an engine layout anywhere. If any one could help me I would very much appreciate it.
Thanks.
Reply With Quote
  #2 (permalink)  
Old 06 May 2011, 06:33 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: PT Hose Problem

Pug, you don't have a problem. That is, if you at least have two hoses still connected to your coolant bottle. The long hose connects to your radiator system, and the coolant goes into and out of that hose. The short hose (if still connected) is connected to nothing. It's for over-pouring mechanics that pour too much coolant into the overflow bottle. When you put too much coolant in, the overflow hose (the short unconnected one) just drains the excess out onto the ground.

Check to see that the short hose is connected to your overflow bottle. When filling your overflow, fill it only to halfway between the upper and lower lines on the bottle--when the engine is cold. Mine won't even allow that much, by the way.

I hope this is your problem. That is to say, I hope you don't really have a problem at all.

Tim
Reply With Quote
Reply

Tags
coolant leak, hose, overheating, radiator


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PCV HOSE HELP robocek Tech & Performance Forum 15 13 Jul 2017 03:37 pm
Where does this hose go? Fuct Tech & Performance Forum 7 09 Jul 2013 06:33 pm
Which hose for vacuum gauge codfather204 Tech & Performance Forum 2 19 Aug 2010 09:48 pm
2006 GT - Swapped Engine Vaccum Hose problem wendelltu General Turbo Discussions 8 12 Aug 2010 05:12 am
Hose head BoyJusCruisin Tech & Performance Forum 2 30 May 2002 12:32 pm


All times are GMT -5. The time now is 04:27 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors