PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Spark but no gas...........

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 May 2011, 06:58 pm
Fresh Cruiser
 
Join Date: May 2011
Posts: 6
Default Spark but no gas...........

New to this site and new to the ownership of a 2001 PT Woody. Bought this car very cheap due to the fact the disassembled head was sitting in the back of the car after "the mechanic friend" replaced a motor mount and then proceeded to pull the entire head assembly off after the car wouldn't start. I reassembled everything with a new timing belt as there appeared to be no mechanical issues. I got everything buttoned up and went to start the car. Everything sounded fine, starter spun strong but no start. Figured I'd give it a shot of starting fluid. Car fired right up and ran great for about 4 seconds until the starting fluid was gone. I can repeat this everytime. I hear the fuel pump running, there's pressure in the fuel rail, TPS has voltage and seems to work properly, but no fuel is getting through the injectors. I have not checked the actual fuel pressure but I suspect this is the reason the prior mechanic pulled the engine apart. I scanned for codes before I tried to start the engine and a bunch came up and me like the idiot I sometimes can be, cleared them. A new coolant code came up but that was probably due to me leaving a water connector unplugged. Any suggestions? Bad computer?
Thanks in advance!
fretless (usually)
Reply With Quote
  #2 (permalink)  
Old 13 May 2011, 09:42 pm
fabreezai's Avatar
Fanatic Cruiser
 
Join Date: Jan 2011
Location: Norad Colorado
Posts: 714
Default Re: Spark but no gas...........

Start with the basics, check all fuses, in the car and under the hood .Check your fuel pressure. Carefully look over all your wiring and there is no damage, make sure your injectors, crank position and cam sensors are plugged in and have a good connection. They are what tell the computer when to have the injectors fire fuel into the engine. Start there, before you go after the computer. If everything checks out then I would borrow/rent a set of "noid" lights (as I know them) that you can connect to the injectors to see if they are calling for fuel/working correctly. Just my 2 cents.

Hope it helps.
Reply With Quote
  #3 (permalink)  
Old 16 May 2011, 11:13 pm
Fresh Cruiser
 
Join Date: May 2011
Posts: 6
Default Re: Spark but no gas...........

Thanks for the info. I've checked all the wiring and fuses more times than I can remember. Can anyone tell me if the crank sensor controls spark and fuel? With the help of a friend today we had the car running for about 5 minutes until the starting fluid ran out. Long enough for codes to come up to find out the injectors aren't opening so guessing it's the cam sensor or crank sensor, which ever triggers spark and also fuel. Getting closer..................
Reply With Quote
  #4 (permalink)  
Old 17 May 2011, 06:39 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Spark but no gas...........

Foound this on a Google search .....

The camshaft position sensor and the crankshaft position sensor both help the pcm establish the rotational position and speed of the engine. The camshaft position sensor helps the pcm determine when to inject fuel to each cylinder and the ignition timing.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 17 May 2011, 08:44 am
Regular Cruiser
 
Join Date: Nov 2009
Posts: 131
Default Re: Spark but no gas...........

This may seem simple but what about the fuel filter? With the adventures of prior guy who knows what else may have happened. Might have a rock in a fuel line.
Reply With Quote
  #6 (permalink)  
Old 17 May 2011, 09:40 am
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: Spark but no gas...........

fuel filter is in tank if you got a rock in your tank where on earth have you been getting gas----not suposed to ever have to change the fuel filter btu then we all know about the never thing
Reply With Quote
  #7 (permalink)  
Old 17 May 2011, 09:54 am
RaineMan's Avatar
Cool Cruiser
 
Join Date: Aug 2010
Location: SL,UT
Posts: 271
Default Re: Spark but no gas...........

Quote:
Originally Posted by fretless View Post
With the help of a friend today we had the car running for about 5 minutes until the starting fluid ran out.
How much starting fluid did you use to get the engine to idle for that long?
Reply With Quote
  #8 (permalink)  
Old 17 May 2011, 10:40 am
Fresh Cruiser
 
Join Date: May 2011
Posts: 6
Default Re: Spark but no gas...........

about 1/2 can. Amazing how long it ran. Maybe it was 3 minutes...I was just so excited it was running
Reply With Quote
  #9 (permalink)  
Old 17 May 2011, 12:42 pm
Fresh Cruiser
 
Join Date: May 2011
Posts: 6
Default Re: Spark but no gas...........

Tried a new cam sensor and still no go. I've got a computer coming tomorrow so hopefully.
Reply With Quote
  #10 (permalink)  
Old 18 May 2011, 11:25 am
Fresh Cruiser
 
Join Date: May 2011
Posts: 6
Default Re: Spark but no gas...........

Put in the new used computer....varoom varoom. Success.
thanks for all the suggestions and input.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
No spark, turns over but no spark? magic1021 Tech & Performance Forum 26 15 Sep 2009 07:50 pm
Spark pulgs and spark plug wires? balvarez814 Tech & Performance Forum 1 13 Aug 2008 08:16 pm
RE: Spark Gap kennybopaloo General PT Cruiser Discussions 13 04 Apr 2006 04:24 pm
Spark Gap kennybopaloo General Turbo Discussions 13 31 Mar 2006 05:09 pm
Spark gap, .50 or .45? clevelandmike Tech & Performance Forum 6 19 Oct 2004 04:08 pm


All times are GMT -5. The time now is 12:02 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors