PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Anchor Motor mounts just bad??? or Bad batch???

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18 May 2011, 05:02 pm
PTCruzing's Avatar
Young Cruiser
 
Join Date: Apr 2011
Location: Elgin,IL
Posts: 68
Angry Anchor Motor mounts just bad??? or Bad batch???

I recently had the motor mounts replaced. When I drove the car home from the shop it ran fine until I got home and could feel a vibration in the car. Took the car back to the shop and was told the lower motor mount is bad already.

I had Rockauto send a replacement and I recieved it today. This is what it looked like. It's bad correct??????





Reply With Quote
  #2 (permalink)  
Old 18 May 2011, 06:28 pm
Dedicated Cruiser
 
Join Date: Mar 2011
Posts: 2,943
Default Re: Anchor Motor mounts just bad??? or Bad batch???

That looks fine to me...probably the shop did not position the mounts correctly.. thats' why you had the vibration
Reply With Quote
  #3 (permalink)  
Old 18 May 2011, 06:32 pm
mityqwik's Avatar
Senior Cruiser
 
Join Date: Sep 2010
Location: Hampton roads Va.
Posts: 1,966
Thumbs up Re: Anchor Motor mounts just bad??? or Bad batch???

the rubber inside of the mounts appear not torn or cracked they look good to me, and i have replaced a few of these on my cruiser ,to many in fact
__________________
It takes 8,460 bolts to assemble an automobile,
and one nut to scatter it all over the road
Reply With Quote
  #4 (permalink)  
Old 18 May 2011, 06:48 pm
azguath's Avatar
Young Cruiser
 
Join Date: May 2011
Location: Phoenix, AZ
Posts: 73
Default Re: Anchor Motor mounts just bad??? or Bad batch???

What i am seeing in the picture you posted



the hole in the upper left is a break in the Mold void. that is typical for Injection molded parts
Reply With Quote
  #5 (permalink)  
Old 18 May 2011, 07:20 pm
PTCruzing's Avatar
Young Cruiser
 
Join Date: Apr 2011
Location: Elgin,IL
Posts: 68
Default Re: Anchor Motor mounts just bad??? or Bad batch???

Thanks for the feedback!!! I placed this photo as I wasn't sure about the hole in the plastic molding. I just wanted to make sure before i took it to the mechanic that it was good. The one on the car is definitely broke all the way around. I didn't want to replace a broken part with another. Thanks for the knowledge as this looked bad to me....
Reply With Quote
  #6 (permalink)  
Old 18 May 2011, 07:51 pm
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,575
Default Re: Anchor Motor mounts just bad??? or Bad batch???

Take it to a mechanic? For a lower mount?!

Take 30 minutes to yourself.

Loosen the bolts holding your passenger tire.

Lift your passenger side enough to slide your tire off. Place vehicle on stand and set tire aside.

With a jack, use a piece of wood and raise the jack to support the engine. Do not raise the height of the engine, simply support it.

Using a 10mm socket (preferably deep socket) remove the 2-3 bolts that hold the lower splash guard/shield. You'll also find 2-3 plastic pins that hold the shield in place, I used needle nose pliers for these. Set shield aside.

You'll see 2 bolts (15mm I believe). These need to be removed in order to pull out the motor mount.

The left bolt has a nut (18mm) remove it. You'll come across a second nut that's part of the long bolt holding the motor mount.

Remove the long bolt (18mm) on the right. Motor mount will slide out of place.
__________________
Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!
Reply With Quote
  #7 (permalink)  
Old 18 May 2011, 09:03 pm
PTCruzing's Avatar
Young Cruiser
 
Join Date: Apr 2011
Location: Elgin,IL
Posts: 68
Default Re: Anchor Motor mounts just bad??? or Bad batch???

Kawizx9r I hear you but I don't have the tools. You'd think after all the cars I've had in the past I would have accumulated a lot by now. Instead, they have slowly disappeared to brothers, friends, etc... I'm not sure if there's a thread of basic essentials needed in a garage but I definitely need to go shopping for stands, jacks, and some tools. I don't mind getting my hands dirty but it's the thought of getting underneath a car with stands, kind of freaks me out a little...
Reply With Quote
  #8 (permalink)  
Old 18 May 2011, 09:15 pm
Dedicated Cruiser
 
Join Date: Mar 2011
Posts: 2,943
Default Re: Anchor Motor mounts just bad??? or Bad batch???

When I change mine I just put the car on ramps and I don't take the wheel out...its as easy to do it like that...and if you need some tools you can always go to Harbor Freight Tools and pick up a set of jack stands for $29 and a nice jack for $59.
Reply With Quote
  #9 (permalink)  
Old 18 May 2011, 09:32 pm
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,575
Default Re: Anchor Motor mounts just bad??? or Bad batch???

Quote:
Originally Posted by XtrmDC2 View Post
When I change mine I just put the car on ramps and I don't take the wheel out...its as easy to do it like that...and if you need some tools you can always go to Harbor Freight Tools and pick up a set of jack stands for $29 and a nice jack for $59.
+1 for Harbor Freight

You can get Craftsman jack stands@Sears for just 20-25.

If you have the supplied jack for your vehicle, you can get away with that.

So spend a few bucks for a 3/8" socket wrench, a 15mm socket, an 18mm socket, a 3/8" to 1/4" adapter, and a 10mm deep socket (for 1/4" socket wrenches).

Shouldn't cost more than $40-50 total (minus jack).

Plus, the 15mm is useful for doing the top motor mount. I know I use my 10mm socket for a few other things in my PT.
__________________
Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!
Reply With Quote
  #10 (permalink)  
Old 18 May 2011, 10:19 pm
PTCruzing's Avatar
Young Cruiser
 
Join Date: Apr 2011
Location: Elgin,IL
Posts: 68
Default Re: Anchor Motor mounts just bad??? or Bad batch???

Thanks guys I will have to check out Harbor Freight Tools....
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Watch out for Anchor motor mounts. tryingbe Tech & Performance Forum 10 26 Oct 2014 01:24 am
Motor mounts hoppyloop General PT Cruiser Discussions 13 02 Jul 2008 11:12 am
motor mounts? 2004PTCruiser Tech & Performance Forum 0 31 May 2008 04:50 pm
PT MOTOR MOUNTS HELP !! BARRYPT General PT Cruiser Discussions 2 18 Jan 2008 12:44 am
motor mounts knowyourturbo Classifieds: For Sale/Trade 1 23 Mar 2006 07:36 pm


All times are GMT -5. The time now is 03:37 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors