PT Cruiser Forum  
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

battery problems

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19 May 2011, 10:26 am
Fresh Cruiser
 
Join Date: May 2011
Posts: 1
Default battery problems

my 04 pt cruiser turbo high output is having battery problems.bought car 2 years ago runs great but 2 months ago i stopped car and tried to start again
nothing i mean nothing no interior lights etc.
replaced battery all ok for 3 months.same problem just now turned car off
and no juice again.very frustrating.can anyone shed some light on the problem.
thanks rapmaster
Reply With Quote
  #2 (permalink)  
Old 19 May 2011, 11:09 am
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 23,724
Default Re: battery problems

You didn't fill in your profile or say where your from but hopefully there's an auto store around you like Pep Boys, Autozone etc. that will check your whole charging system for free. Did you do that the last time you put the new battery in?

If the alternator isn't charging the battery as it gets used, you'll completely
discharge the battery. Depending on how much you use the car, it could take awhile before it goes dead.
__________________
......
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 118,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Visit My Home Page www.CREWZIN.com
Reply With Quote
  #3 (permalink)  
Old 19 May 2011, 11:24 am
2wdlaser's Avatar
Fresh Cruiser
 
Join Date: May 2011
Posts: 8
Default Re: battery problems

Sounds like an alternator to me.
Reply With Quote
  #4 (permalink)  
Old 19 May 2011, 11:58 am
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 6,209
Default Re: battery problems

curzen is right have the charging system checked make sure the conections are clean and tight
Reply With Quote
  #5 (permalink)  
Old 24 May 2011, 03:34 am
Fresh Cruiser
 
Join Date: May 2011
Posts: 1
Default Re: battery problems

you know about this.. try it.. this may be very useful ..Batteries must be kept clean and dry. If the top surface of the battery gets dirty or wet, a small flow of electricity will flow between the terminals as the water creates a conductive path. If installed in a location where water can drip onto them, this can cause the batteries to discharge fairly rapidly.

Last edited by CREWZIN; 24 May 2011 at 06:17 am.
Reply With Quote
  #6 (permalink)  
Old 25 Jun 2011, 02:24 pm
Fresh Cruiser
 
Join Date: Jun 2011
Location: COOK ISLANDS
Posts: 1
Default BATTERY DRAIN PROBLEM

the battery goes flat every second day. did battery amp draw and got 0.13amps from 4 fuses under the hood of the car. 1). IOD 0.02amps. 2) pwr 0.04amps has been fixed. 3) lighting 0.02amps 4) eatx 0.05amps. so are these normal? if not can you please advise on where to look for any fault.

cheers
Reply With Quote
  #7 (permalink)  
Old 25 Jun 2011, 06:50 pm
xwing777's Avatar
Fanatic Cruiser
 
Join Date: Jan 2009
Location: Taylorsville NC
Posts: 986
Default Re: battery problems

Take your grounds loose beside battery and clean. Betting you will find loose or corroded wires there. It also wouldnt hurt to add another bigger wire from engine block to battery and another from body of car to battery on the grounds.

These cars have poor wiring and if not kept pristine will cause havoc
__________________
.

My rides: 2004 Almond GT, autostick - Only car shows, some weekends but with Stage1!
2003 cranberry 5 speed GT - Fishing with a sleeper Stage3 setup!

Her Ride: 2006 Electric Blue Touring, auto -Daily driver, car shows with tons of A/V!

Reply With Quote
  #8 (permalink)  
Old 28 Jun 2011, 04:28 am
Fresh Cruiser
 
Join Date: Nov 2010
Posts: 5
Question Re: battery problems

I have on '02 Cruiser, battery replaced 5/22/11. got off work and it started without any hesitation. Drove 4 miles to gas station. tried to start after fill up and would only click. All other electrical and lights worked fine, just would only give me a click. got a jump and turned over without any hesitation.

Would a faulty alternator cause this issue?
Reply With Quote
  #9 (permalink)  
Old 28 Jun 2011, 07:53 am
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 23,724
Default Re: battery problems

It might if it's not charging up the battery but you'll never know unless you get your charging system checked. As was said earlier, many places will check the charging system and the battery for free.
__________________
......
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 118,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Visit My Home Page www.CREWZIN.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Problems??? PTJake Tech & Performance Forum 0 18 May 2007 06:04 pm
Battery cruiser33 General PT Cruiser Discussions 7 16 May 2006 08:28 am
battery twinturbo General Turbo Discussions 7 20 Mar 2004 04:49 pm
Battery Box Hudd General PT Cruiser Discussions 6 24 Nov 2003 09:28 pm


All times are GMT -5. The time now is 06:40 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors