PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Dead Battery???

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 26 May 2011, 08:04 pm
Young Cruiser
 
Join Date: Feb 2010
Location: Buffalo,NY
Posts: 56
Default Dead Battery???

Car has been sitting for 2 weeks. I had new battery out in, in february. Went to run the car today and it would not start, no clicking or lights, just dead. Have not tried to jump as rain storm is goin crazy outside. Does it sounds like a quick jump would fix this issue? Also when I had the new battery put in the charging system was checked and everything came back ok.
__________________
2005 Pt Cruiser Convertible Touring Edition
Jvc KD-R300 Dash Unit
Kicker K35 3.5in Dash Speakers
Pioneer TS-A1673R 6.5in Door
Pioneer TS-A6963R 6x9 Rears
Infinity Kappa 12in Sub
Infinity REF5350A 5 Channel Amp

Last edited by Afitch628; 26 May 2011 at 08:23 pm.
Reply With Quote
  #2 (permalink)  
Old 26 May 2011, 08:50 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: Dead Battery???

Afitch, you might check the battery and terminals for corrosion. I know your battery is new, but I had Sears install a new battery a few years back and the mechanic didn't put any battery protectant on it (he also busted one of the male prongs to my air cleaner box).

So, here I was thinking I had a new battery and all was well with the world. The thing is, my PT has the elongated air box cover that completely covers the battery. I believe this traps more hydrogen gas and promotes the corrosion of the positive battery post and its clamp. I also suspect that's why Chrysler redesigned the air box cover so that the positive post is now exposed.

Anyway, within a few months--especially with no battery protectant sprayed onto the posts and clamps after the installation of the new battery--the corrosion caused the clamp to corrode beyond cleaning. I actually needed an entirely new wiring harness as a result.

Check the connections at your battery. If corroded, then clean them up. But make sure you spray CRC Battery Protector on the clamps and posts after connecting them up again. Ever since I found this stuff, I've had no more problems.

By the way, I also replaced the thermal blanket that had "disappeared" after the Sears Fiasco, and it really helped with slowing water evaporation from the battery cells.

Good luck,

Tim
Reply With Quote
  #3 (permalink)  
Old 26 May 2011, 08:55 pm
Regular Cruiser
 
Join Date: Sep 2009
Location: Michigan
Posts: 135
Default Re: Dead Battery???

It is possible that two weeks of sitting could cause the battery to discharge, I woluld hope a brand new battery would last longer but maybe todays batteries aint what they used to be.
Have you confirmed that their is nothing draining the battery?
Reply With Quote
  #4 (permalink)  
Old 26 May 2011, 09:09 pm
Young Cruiser
 
Join Date: Feb 2010
Location: Buffalo,NY
Posts: 56
Default Re: Dead Battery???

Yes there were no light switches engaged or doors ajar. Funny that you mention wires because when I got the first new battery it had a bad solenoid so they replaced that with the current battery and I asked if they cleaned the terminals and the battery tray, ofcoarse they said yes. After an inspection I noticed they did not, so I will have to look more closely at that. Im going to go and try to jump it now as the rain has stopped.
__________________
2005 Pt Cruiser Convertible Touring Edition
Jvc KD-R300 Dash Unit
Kicker K35 3.5in Dash Speakers
Pioneer TS-A1673R 6.5in Door
Pioneer TS-A6963R 6x9 Rears
Infinity Kappa 12in Sub
Infinity REF5350A 5 Channel Amp
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead Battery???? I think not... cruisergeo Tech & Performance Forum 12 02 Sep 2016 04:32 pm
Completely dead battery after parking for 1 month. problem? hushpuppy General PT Cruiser Discussions 16 08 Jul 2010 10:43 pm
Dead Battery? dveldt Tech & Performance Forum 10 28 May 2010 04:59 pm
dead battery overnight strokedmaro Tech & Performance Forum 2 11 Sep 2009 09:15 pm
Dead battery at 33K miles sawdust123 General Turbo Discussions 14 16 Dec 2005 05:56 pm


All times are GMT -5. The time now is 05:43 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors