PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Is it my alternator??

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Jun 2011, 09:39 pm
Fresh Cruiser
 
Join Date: Jun 2011
Posts: 2
Lightbulb Is it my alternator??

I just joined and am looking for some help. MY 2002 PT Cruiser with about 72,000 miles, has been experiencing heat stroke , or something. Firestone changed my battery and changed the oil gasket 3 days ago. I ran a short errand this morning and in the early evening, I noticed yet again, I need to jump start the battery. I checked the paperwork, Firestone said that the alternator tested low, but was still within specs, they recommended that I get a radiator flush, but I had that done a bout 6 months ago. Is this an alternator problem? I really love my baby, but she seems to be reacting to the quick weather changes that we have been having here in Chicago. Can anybody suggest something???
Reply With Quote
  #2 (permalink)  
Old 06 Jun 2011, 06:55 am
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: Is it my alternator??

Welcome to the Forum!!!!!

Firestone WILL always find something wrong with your car!!! Having said that, what does a dead battery, low specs on the alternator and a radiator flush have in common? Nothing that I know of. Go to a Action Auto etc. and have them check your battery under load, it is possible you have a bad battery, it happens!! Good Luck.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #3 (permalink)  
Old 06 Jun 2011, 04:08 pm
Regular Cruiser
 
Join Date: Nov 2009
Posts: 131
Default Re: Is it my alternator??

Ditto to what Hooligan stated.
Reply With Quote
  #4 (permalink)  
Old 06 Jun 2011, 06:08 pm
Fresh Cruiser
 
Join Date: Oct 2010
Posts: 42
Default Re: Is it my alternator??

I had the same problem. Took it to get checked at pepboys and they told me that alternator was good. Took it to autozone and was told it was bad. Went back to pepboys because it came with a lifetime replacement on it when I replaced it the first time. They checked again still said nothing wrong with it. After showing them the spec sheet that autozone printed after they tested it and refusing to leave untill they replaced it, 30 minutes later new alternator and everything has been just fine. Now I have a new problem I am trying to figure out, overheating.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 gt with bad alternator jacarc1 General Turbo Discussions 5 31 Mar 2010 03:47 pm
H/O Alternator jonnbr Sound and Security Forum 0 18 Nov 2009 02:08 am
alternator hillbilly678 Tech & Performance Forum 4 05 Nov 2009 02:51 pm
Alternator Mark Tech & Performance Forum 0 13 Feb 2002 05:46 pm


All times are GMT -5. The time now is 03:37 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors