PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2007 base fan problems

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 Jun 2011, 03:18 pm
Fresh Cruiser
 
Join Date: Jun 2011
Posts: 3
Default 2007 base fan problems

I've been able to read a fair amout about this problem in forums, but they always seem to be older pt's so that's why i'm posting here. i have a 2007 base(canadian ) pt cruiser. awhile ago it started surging with the compressor. went and had the cooling juice refilled and that helped alot but was told my fans aren't working. turn on the ac and the fan doesn't start. strange thing is that the car hasn't overheated yet. perhaps it's just not hot enought or i haven't been stuck in traffic long enough. it does make the compressor surge if i'm sitting for too long and have the ac on. tried the 50amp fuse. not the problem. any ideas? i think it's probabley the fan motor at this stage but any ideas as to what or how to test would be welcome.
thanks.
Reply With Quote
  #2 (permalink)  
Old 08 Jun 2011, 03:21 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: 2007 base fan problems

to me its way easier to get a new fan put it in and be done with it if the shop said they are not working Id say they are not its a way common problem and they have dual relay fans on ebay for under a bengimun its a cheap price for not over heating you engin
Reply With Quote
  #3 (permalink)  
Old 08 Jun 2011, 03:27 pm
Fresh Cruiser
 
Join Date: Jun 2011
Posts: 3
Default Re: 2007 base fan problems

that's part of the reason i'm posting here. i don't know if my model has these duel fan relays or just the 50amp fuse. if so, where are they? how do i check them? they want 500 bucks for the fan set up here plus installation at 150hr
Reply With Quote
  #4 (permalink)  
Old 08 Jun 2011, 07:29 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: 2007 base fan problems

Rick, Welcome!!
The relays are on the firewall drivers side. I doubt it is the relays tho. All of the PT's have a two speed fan and you have been told that the problem is the fan!! You can do the job yourself in just a couple hours. If you look in the Performance section you'll find a sticky on how to change it out. All you need is a fan motor, check with a auto supply store in your area or e bay.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 08 Jun 2011, 10:30 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: 2007 base fan problems

Rick, just get a new fan at rockAuto.com, or E-Bay. They can't be any worse than the OEM. The price for the whole fan is almost the price of the new motor and brushes. And look up on here how to replace it.

By the way, when my fan went out, my engine never did overheat. It was in the early spring of last year so the ambient temperature was not above 70 degrees Fahrenheit. In fact, the temp gauge never went above its normal almost-halfway-position.

I would not have known my fan was not working properly, except for the fact that my A/C while on--and at idle--was causing my engine to sputter. Also, the A/C would not blow cold at idle. Turns out, it was the fan ... despite the fact that the same fan was supposed to be cooling my engine coolant.

I can only assume that since we don't live in a high-traffic town--thus little time spent at Stop signs and Stop lights--and since it was not high summer, where the temperature here seems to stay at around 105 for a good two months straight, that our PT's don't really get too hot when the fan's on the fritz.

Tim
Reply With Quote
  #6 (permalink)  
Old 09 Jun 2011, 09:22 am
Fresh Cruiser
 
Join Date: Jun 2011
Posts: 3
Default Re: 2007 base fan problems

thanks guys for the info. have to find the link on how to replace it. getting th e parts looks like the easy part. installing it looks like it'll be a real beach.
Reply With Quote
  #7 (permalink)  
Old 30 Jan 2012, 03:19 pm
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 1
Default Re: 2007 base fan problems

What was the problem? I am having the same issues on my 2007 pt cruiser. Thanks.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 PT Cruiser Check engine light and transmission problems. jpierce2087 Tech & Performance Forum 18 22 Oct 2015 08:30 pm
2007 convertable .... Problems.... HELP Lottie PT Cruiser Convertible Forum 3 16 Apr 2011 02:41 pm
Parting Out 2005 PT Cruiser base base model taftboys Classifieds: For Sale/Trade 9 07 Oct 2010 07:13 pm
2003 Base PT Engine Electrical Problems GaryD Tech & Performance Forum 5 29 Nov 2009 01:51 pm
Is there a pcv on an '06 base PT? 66CUDA Tech & Performance Forum 2 02 Jun 2009 08:26 pm


All times are GMT -5. The time now is 03:55 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors