PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
New alternator not charging, how to check ECM? P0622

 
Like Tree7Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 13 Aug 2012, 06:34 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: New alternator not charging, how to check ECM? P0622

Well, you get a rack of beer and a stack of cookies!!!




You prolly saved tons of headaches!


Quote:
Originally Posted by imalittleturt View Post
I'm glad I could help. This forum has saved me tons of time and lots of money by guiding me through repairs. I happy I could help someone else out.

I was super frustrated throughout this repair because I could not find enough information about the issue so I am glad you could find my post and resole your issue.
Reply With Quote
  #12 (permalink)  
Old 20 Jun 2013, 09:43 am
Fresh Cruiser
 
Join Date: Jun 2013
Posts: 1
Default Re: New alternator not charging, how to check ECM? P0622

Thanks for this thread! this should be sticky!!!!!!
Reply With Quote
  #13 (permalink)  
Old 31 Dec 2013, 07:20 am
Fresh Cruiser
 
Join Date: Mar 2012
Location: hernando mississippi
Posts: 6
Default Re: New alternator not charging, how to check ECM? P0622

i was having the same problems with my daughters 04 cruiser ,my daughter had taken it to a local shop and they had told her it was the ecm ,i searched the forum and ran across this post , crawled under the car looked at the wires and the green wire was just holding on by threads repaired the wires and car is running fine ,no more battery light thanks a bunch for this forum
Reply With Quote
  #14 (permalink)  
Old 02 Jan 2014, 12:09 am
Regular Cruiser
 
Join Date: Jun 2005
Location: Ventura, CA, USA.
Posts: 150
Default Re: New alternator not charging, how to check ECM? P0622

Quote:
Originally Posted by JERDOY View Post
i was having the same problems with my daughters 04 cruiser ,my daughter had taken it to a local shop and they had told her it was the ecm ,i searched the forum and ran across this post , crawled under the car looked at the wires and the green wire was just holding on by threads repaired the wires and car is running fine ,no more battery light thanks a bunch for this forum
Which CV shaft does it cross over? Driver's or passenger's side? I'd like to inspect ours.
__________________
______________________________________________
Most misunderstandings in the world could be avoided if people would simply take the time to ask, "What else could this mean?
______________________________________________
2001 PT Cruiser LE 5 spd, original owner, no mods, MOOG arms with spherical bushing (ride is now a bit harsher vs OEM)
- 109K replaced timing belt/WP/tensioner/idler/crank&cam seals with same 1st gen design. That was a fun day and half!
- 119K Gates water pump failed after only 10K miles. Replaced with Airtex. This time around it was a 7 hour job.

2001 PT Cruiser LE AT 59K miles. Bought used, newest addition to the family
Reply With Quote
  #15 (permalink)  
Old 02 Jan 2014, 04:31 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: New alternator not charging, how to check ECM? P0622

All that is on passenger's side-

Something similar was really common on Neons, wires to rear O2 sensor would fall on axle, and O2 heater would short- Causing fuel pump fuse to blow and car to stop.
Unfortunate
Reply With Quote
  #16 (permalink)  
Old 05 Jan 2014, 12:14 am
Fresh Cruiser
 
Join Date: May 2012
Posts: 47
Default Re: New alternator not charging, how to check ECM? P0622

Gosh, the alternator placement is a real drag.
Still having charging problems. Got cheap jack stands for Christmas but as it's a gravel space, didn't want to go under.
As I've pulled a 0622, I wanted to know more about this possible chafing problem.

Reading others' fixes, I'm curious about some of the terminology - what's considered the "harness," and what's considered the braid or braided sheath? I've also seen the term "loom" used.

I see sort of the plastic-y ridged tube ending at a cloth-type connector after which green and brown wires wrap around, leading up to the alternator... It also looks like the green wire is coiling around the plastic tubing?

Also trying to discern where this wiring bundle ultimately ends up in the other direction. Darned manifold.

Or am I barking up the wrong tree?

Reply With Quote
  #17 (permalink)  
Old 05 Jan 2014, 04:06 am
Senior Cruiser
 
Join Date: Jan 2013
Posts: 1,096
Default Re: New alternator not charging, how to check ECM? P0622

Random; a wiring harness is a bunch of wires usually taped together. A braided sheath is a covering over these wires made of a cloth type material. Kind of like a Chinese finger. A loom is also a covering for a harness, but [today] is made of ribbed plastic [as seen on your pic]. This may not be totally right, but good enough?

0622 = alternator field circuit. --- For a 2003 sebring [same engine] the circuit goes from the battery thru pdc [fuse # 14] to asd [auto shutdown relay in pdc] to pcm [computer] thru pdc [fuse # 25] to 2 prong plug into alternator to brushes and back out to pcm. Any poor connection or broken wire could cause this code. None of this applies if you have a 2006 or older PT.

The large [red?] wire bolted to the alternator goes to the big lug on the starter. It should turn to a smaller sized green wire near the starter. This special attached green wire is a fusible link. Basically a one time fuse.

There may also be a large black wire connected to the aluminum framework of the alternator used as a secondary ground. I don't know.
Reply With Quote
  #18 (permalink)  
Old 03 Nov 2015, 07:17 pm
Fresh Cruiser
 
Join Date: Nov 2015
Posts: 2
Default Re: New alternator not charging, how to check ECM? P0622

Hello forum! I'm new here but I'm trying to be the proud new owner of a PT cruiser lol. I realize this is an older post but I'm having the same problem. I just bought a 2006 signature series with 98,000 miles and it wasn't charging the battery. I had alternator checked and then noticed the same code pulled and at least one of my wires running to the alternator were worn through. I used a butt connector to reconnect but I'm still pulling the same code and battery light is on. The previous post to mine sounded hopeful for things to check but he says it isn't relevant for 2006 on? Any suggestions? I'll be forever grateful bc this thing is getting to be beyond me!
Reply With Quote
  #19 (permalink)  
Old 23 May 2017, 11:00 am
Cool Cruiser
 
Join Date: Sep 2014
Location: Northridge, California Baby
Posts: 237
Default Re: New alternator not charging, how to check ECM? P0622

I'm resurrecting this thread just to say how glad I am that I found it. I had pretty much the same problem this past week with no power from the alternator and after removing and testing it (it was good), charging and testing the battery (it tested as bad, but would take a charge), and replacing the positive battery connector (there was lot of corrosion under and on the wire) I was getting close to stumped.

Then I read this thread, pulled my ramps out of storage, and crawled underneath the car. I felt along the wires and sure enough, right above the axle where I couldn't see, the wires were touching it. The plastic wire covering was a bit worn away on the larger wire and the feed line (the black wire) to the alternator was worn right in half. I could've saved myself several days if I had checked this first. Oh well, it was a cheap and easy fix in the end at any rate.
rckstein likes this.
Reply With Quote
  #20 (permalink)  
Old 16 May 2018, 07:35 pm
Schlyder's Avatar
Young Cruiser
 
Join Date: Jul 2014
Location: southeast Sasktchewan, Canada
Posts: 52
Default Re: New alternator not charging, how to check ECM? P0622

Right on. I just found a code 0622. This is where I will start. Thanks man.
__________________
1
2002 Limited Edition
2.4l NA
auto trans.
242,000 km

2 project.
2001 Limited Edition
2.4l NA
auto trans.
155,000 km
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Charging problem lowridr General PT Cruiser Discussions 4 03 Nov 2010 09:18 am
Charging the Air Conditioner chuck2112 Tech & Performance Forum 11 23 Feb 2010 09:44 pm
UK crd charging question spiceweasel Tech & Performance Forum 6 15 Dec 2007 04:37 pm
Looking for charging system mods oldcoach General PT Cruiser Discussions 0 27 Oct 2007 05:16 am
Super charging Mr.Blonde Turbo Performance 7 29 Apr 2003 10:31 am


All times are GMT -5. The time now is 11:16 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors