PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Noob with A/C problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Jun 2011, 12:24 am
Fresh Cruiser
 
Join Date: Jun 2011
Posts: 2
Default Noob with A/C problem

New here with a question regarding the A/C system.


PT Cruiser with just over 100,000 miles had a weird smell (not trans fluid, not engine oil, and not engine coolant) followed by the A/C blowing warm. Compressor is clicking on and radiator fan is kicking on when A/C button is engaged. Checked the LOW A/C port with a gauge and its showing almost no pressure. My questions are basically, Why is the compressor still working? Which lines are more prone to leaks?

Thanks in advance for any advice. I am dying here in the desert of New Mexico in a black PT with no A/C. I will try to add some refrigerant but I know it will just leak out.

Thanks,
Tino
Reply With Quote
  #2 (permalink)  
Old 17 Jun 2011, 05:17 am
OrlandoSB's Avatar
Fresh Cruiser
 
Join Date: Jun 2011
Location: Orlando, Florida
Posts: 35
Send a message via AIM to OrlandoSB Send a message via Yahoo to OrlandoSB Send a message via Skype™ to OrlandoSB
Default Re: Noob with A/C problem

My AC was blowing cool, not cold. Compressor was kicking on and off too. Took it to a Meineke shop just to get some quick advice, they wanted 100 bucks just to boost charge it. Same with Pep Boys, 78 bucks. Went to Walmart and got a can of EZ Chill for 25 bucks and now blows cold and holding the charge after 3 weeks. I would suggest taking it to a shop and have them charge it and they can put a dye in there and see where its leaking from.

Hotter than a EZ Bake Oven in hell, here in Orlando too, we need our A/C!!
Reply With Quote
  #3 (permalink)  
Old 23 Jun 2011, 03:52 am
Fresh Cruiser
 
Join Date: Jun 2011
Posts: 2
Default Re: Noob with A/C problem

I did find the culprit hose. Apparently it got damaged from bottoming out the front end on a high driveway. It is the line with the high pressure service port. Had a problem getting it out though. Just snipped the rubber line in half and pulled it out. Took it to a place to have barbs welded on making future replacement of the rubber hose a snap.
Reply With Quote
Reply

Tags
a/c, air conditioning, leaks, refrigerant


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Noob hello scrw General PT Cruiser Discussions 3 29 Nov 2009 12:02 am
Noob Thanks EDGEFIND General PT Cruiser Discussions 3 26 Nov 2009 02:44 pm
Noob with a serious oil leak, Help... TSPalmer Tech & Performance Forum 7 13 Dec 2008 01:08 pm
Help a Noob!! warped General PT Cruiser Discussions 5 20 Oct 2007 12:27 pm
serious noob question caraloco Stage Turbo Kits 13 02 Aug 2007 04:31 pm


All times are GMT -5. The time now is 08:25 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors