PT Cruiser Forum  
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Oil Light and "Ding!"

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 28 Jun 2011, 08:21 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,305
Default Oil Light and "Ding!"

Hello, Cruisers!

I tried to do a "Search" on this subject, but I'm obviously doing something wrong. I type "Oil Light" into the forum's Search--and I get today's stuff. Not posts relating to the oil light, or oil light problems ....

Still, I have a question: My wife told me today (belatedly) that when she started the PT last week--after it had sat all night--that the oil light came on and she heard a single "ding!". She immediately turned off the engine and turned it back on. The oil light didn't come on--and no ding sound, either. She drove it for a week with no problems.

So for a week, no more oil lights and no more dings. But this morning she started the car after it was sitting all night, and the oil light came on again--and she heard a single "ding" again. She turned off the motor and started it again and there was no oil light and no ding.

I checked the oil, first thing--and it was at the full mark. No oil leaking, of course, either. The oil was not hot (the engine had been sitting an hour before she told me of these symptoms, however). I asked her if the car ran hot or she smelled anything funny. She said the temp gauge remained at normal, halfway--and no smells.

Do I have a sending-unit problem? Has anyone encountered this issue?

Let me know what you know.

Thanks,

Tim
Reply With Quote
  #2 (permalink)  
Old 28 Jun 2011, 08:26 pm
VNT's Avatar
VNT VNT is offline
Senior Cruiser
 
Join Date: Jun 2009
Location: NE
Posts: 1,379
Default Re: Oil Light and "Ding!"

Sounds like the sending unit, get a new one and replace it. It is a PITA to get to.
__________________
VNT

89 Shadow ES 2.5 T2 +20's A555
86 TurboZ CS 2.2 T2 +20's A555
90 Daytona ES 2.5 T1 A523
90 Datyona Shelby VNT needs work
00 Durango SLT+ 5.9 4x4
02 Grand Cherokee 4.7 4x4
03 PT GT Black 5 sp Stg 1
05 PT GT Silver 5 Spd Conv
06 PT GT Cool Vanilla 5 spd Conv
06 PT Base Marine Blue 40TE Conv
Reply With Quote
  #3 (permalink)  
Old 28 Jun 2011, 10:32 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,305
Default Re: Oil Light and "Ding!"

Okay, I did the key dance and got two codes. One was P0522 (Oil Pressure Sending Unit input below acceptable voltage). So it looks like the oil pressure sending unit. I looked for it but it's obviously in a well-hidden place--even though I have a pic of it. I looked from above the engine, however.

I also got this little kick in the butt: P0325 (Knock Sensor signal above or below minuimum acceptable threshold voltage). What the hell is a Knock Sensor? Where is it? What does it do? Is it more accessible than the Oil Pressure sending unit? I hope so.

Tim
Reply With Quote
  #4 (permalink)  
Old 29 Jun 2011, 10:42 am
Fresh Cruiser
 
Join Date: Jan 2009
Location: antioch,il
Posts: 17
Default Re: Oil Light and "Ding!"

Quote:
Originally Posted by mdfrodolives View Post
Okay, I did the key dance and got two codes. One was P0522 (Oil Pressure Sending Unit input below acceptable voltage). So it looks like the oil pressure sending unit. I looked for it but it's obviously in a well-hidden place--even though I have a pic of it.

Tim
It's not easily seen from above. From below the car, it's a little to the driver's side. There is a wire coming off the alternator that hides it. You will most likely see the neon green connector that plugs into the sensor. Don't fret, it took me awhile to find it too. They sure don't make it easy to get to, that's for sure. Hope this helps.
__________________
silver 2004
Reply With Quote
  #5 (permalink)  
Old 29 Jun 2011, 09:58 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,305
Default Re: Oil Light and "Ding!"

Well, I actually got the Search engine on this forum to work for me. I just switch from Threads to Posts--and sometimes visa versa. Sometimes it works, sometimes I still get the day's posts--instead of the item I was searching for. Go figure.

The Knock Sensor code, I'm going to attribute to some lousy gas I bought a few weeks ago. If, after I erase the code, it shows up again, then I may be running lean, and will regap my plugs to .38. Although, I gapped them at .45 when I put them in and there were no Knock Sensor problems in several thousand miles.

I finally found the Oil Pressure sending unit. It may as well be on someone else's car--it's so inaccessible. I'll try checking it out from under the car this weekend when I have time to put it up on jackstands and all that. If I can reach it from below, I'll do the job myself. I'd try from above, but I don't fancy moving the PCM box, like one old poter said to do.

Later, guys.

Thanks.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
"no fuse" light came on!!! hermtm2 General PT Cruiser Discussions 21 30 May 2014 01:15 am
2002 Pearl Almond Limited Pt "Custom Route 66 " Edition rt66pt Classifieds: For Sale/Trade 59 03 Mar 2013 11:49 pm
Turbo "phhsssss" or "whoosh" sound--Normal? Silenceable? Help! Memark General Turbo Discussions 13 24 Nov 2010 09:56 pm
Part number for "PT" door emblems on 2008 Dream Cruiser 5 gpr75 General PT Cruiser Discussions 6 16 Jul 2010 12:15 pm
tach'd up & the "brake light" flashes Hedgapple General Turbo Discussions 4 03 Jul 2007 09:50 pm


All times are GMT -5. The time now is 05:20 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors