PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Electrical Issue

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15 Jul 2011, 12:52 pm
Fresh Cruiser
 
Join Date: Jul 2011
Posts: 1
Default Electrical Issue

After I get my Cruiser started the key will come in and out freely, just like the cars of the 50s and 60s. After I turn the car off the ignition must be put exactly in the off position or the battery will drain. Very frustrating!
Reply With Quote
  #2 (permalink)  
Old 15 Jul 2011, 01:00 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Electrical Issue

Welcome to the forums.
Sounds like your ignition switch is going/gone. I believe it's not that expensive.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical issue? DMod General PT Cruiser Discussions 38 23 Jan 2012 08:49 pm
electrical problem. burning electrical plug cruiserjim269 General PT Cruiser Discussions 17 03 Dec 2010 03:38 pm
07 Fan/electrical issue? megamatt77 Tech & Performance Forum 2 23 Jun 2010 03:38 pm
need electrical help thundercat2 Tech & Performance Forum 0 27 Sep 2008 08:02 am


All times are GMT -5. The time now is 11:21 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors