PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
AC problems

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Jul 2011, 05:24 pm
Fresh Cruiser
 
Join Date: Nov 2010
Location: Arizona
Posts: 41
Default AC problems

The AC worked fine, winter came along with several trips back to sellers shop. Someone rear ended someone in my pt resulting in a new radiator being put in. Radiator works fine but when I turned on the ac hot air blows. Ive filled with freon not once, but 3 different times. On the first attempt I heard the compressor kick on but seems the freon went to heaven or something because the gauge eventually showed no pressure as well as the compressor not kicking back on. I changed the seals and added more freon once again, I heard hissing and smelled it. I couldnt figure out where it was coming from until the other night after engine cooled I thought I might feel around where I had heard the hissing sound trying to find the leak possibily,
I went to auto zone and tried stop leak that had freon an leak repair in one. right! As some of you know, Im by meself when trying to figure out this cars problems so try and bare with me, Im doing the best that I can.
Anyway, The can of leak repair didnt work, again I heard it start hissing and smelled the freon again.
I read the instructions on testing the clutch switch ? using a paper clip, inserting into the holes and cranking the engine/w AC on.. Nothing happened. Cant remember if it needs pressure in the lines to kick it or not?
Upon feeling around the ac lines I felt a tear in the rubber part of the tubing, the one thats closest to the frame, outside I guess. when I lifted up on it I could see the point where it connects to the bottom of my radiator that it wasnt lined up exactly and moves around... I can literally lift that ac line and the bottom of the radiator moves. Im not sure what to do. Its 115 almost everyday here in phx and I cant take much more. Im now gonna jack up the front and try to see if when the ......... crashed my car, the impact of the crash slammed/shoved something forward into the compressor/radiator, putting it out of alignment possibly or cracked something or something? Ive no idea.. In search of.. Let me know what you think my next move should be. Your advice is golden to me. Its getting late and the auto parts stores are gonna close soon but Im on this until the ac is back working. Thanks so much.

Last edited by Leannaluv; 16 Jul 2011 at 05:31 pm.
Reply With Quote
  #2 (permalink)  
Old 16 Jul 2011, 05:54 pm
Fresh Cruiser
 
Join Date: Nov 2010
Location: Arizona
Posts: 41
Default Re: AC problems

Is anyone home. Times zones are much different, Im wrenching when you guys are sleeping or bar hopping.. Helpppppppppp..
Reply With Quote
  #3 (permalink)  
Old 16 Jul 2011, 05:59 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: AC problems

If you felt a tear in the rubber part of the tubing, there's nothing you can do but replace it. You've also lost enough freon (R134a) to need a shot of lubricating oil mixed in with the re-charge. Sorry, but it seems you need professional help at this point to make sure the point of connection with the radiator isn't broken or cracked.

Your trick with the paper clip won't work if your not fully charged up with freon. The compressor's high pressure switch won't let the compressor turn on if your low.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 16 Jul 2011, 09:35 pm
Fresh Cruiser
 
Join Date: Nov 2010
Location: Arizona
Posts: 41
Default Re: AC problems

I jacked up the front end to see if I could locate the leak, hole, loose connection? The main AC line just came right off, the screw was so loose making the freon leak out. I took off the grill and reconnected top and tightened the bottom as well. Off to auto zone I went, bought a can of R... started the flow slowly with motor running and AC on. waiting, waiting. One of the guys from the store watching me as I didnt want to screw it up. Bad idea...... give me a breakkkkkkkkk. I overfill it, release some pressure, waiting waiting. didnt happen, Fan kicks on but not the compressor. The good knews is I didnt hear or smell any freon. So at this point I did the paper clip again? Im not sure if Im even jumping the right item, is it the canister sitting against the sidewall on the left side? I unplugged it and put the two pc ends into the top of the plug, right? started the car, turned on the AC... NOTHING............could that be my problem? or do I need to take it in? If thats the case Im going straight down to a used lot and trading this pile of crap in. Then Im suing the jerk who sold me this worn out car. Which way do I go .. left or right down to the used car lot............................. thx.
Reply With Quote
  #5 (permalink)  
Old 16 Jul 2011, 09:41 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: AC problems

It's the switch on top of the accumulator, but I still think you need professional help.

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #6 (permalink)  
Old 17 Jul 2011, 07:53 pm
Fresh Cruiser
 
Join Date: Nov 2010
Location: Arizona
Posts: 41
Default Re: AC problems

I probably do but no cash...My normal mechanic tells me that its the filter in the ac pipe. He says its probably clogged. He told me Id be able to see it after taking them apart, Did that and pretty much just lost all my freon and got oil everywhere. It seemed like it was steamy or condensation perhaps? No idea. Im on my way to his house uin announced..lol.. He wont get away this time. Besides, he's probably the one who didnt connect it all the way after fixing my motor mounts. Im thinking he guilty I cant tell him that of course... brb.. . And my bo of course. Everyone breaks my car and I have to suffer and go through hell trying to fix their mistakes.
Reply With Quote
  #7 (permalink)  
Old 17 Jul 2011, 08:22 pm
Fresh Cruiser
 
Join Date: Nov 2010
Location: Arizona
Posts: 41
Default Re: AC problems

Gonna be hot tomorrow.....=(

Last edited by Leannaluv; 17 Jul 2011 at 11:38 pm.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
IOD Problems?? loneleix General PT Cruiser Discussions 4 21 Jun 2010 01:50 am
PT Problems... MrGrim General PT Cruiser Discussions 2 09 Mar 2010 09:59 am
Fan problems Alex6163 Tech & Performance Forum 2 13 Jul 2009 04:44 pm
PT problems AquamarinePT Tech & Performance Forum 9 09 Jul 2009 07:51 pm
Help! Problems with my 05 Ptcruzer07 Wheels, Tires, Suspension 6 10 Apr 2009 07:52 am


All times are GMT -5. The time now is 06:30 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors