PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Radio not receiving power?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 Jul 2011, 02:33 pm
Fresh Cruiser
 
Join Date: Jul 2011
Posts: 5
Default Radio not receiving power?

I recently changed my instrumental panel lights on my 2002 pt cruiser. I followed the directions that were listed in the thread located here. Some of the lights are not working but that may because i installed them the wrong side(flip them over). Seeing that all the lights are currently not on the instrument panel is it causing my radio to not receive power?

May my battery be going bad?

Thanks in advance for any help
Reply With Quote
  #2 (permalink)  
Old 25 Jul 2011, 09:17 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Radio not receiving power?

Try 2 things -
If you have an adjustible steering wheel, try moving it (harness gets pinched).
Push in on the ignition key - sometime the locks start to get loose and not make contact.
Both of those have been reported helping others with similar problems.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 25 Jul 2011, 03:13 pm
Fresh Cruiser
 
Join Date: Jul 2011
Posts: 5
Default Re: Radio not receiving power?

It seem my radio got fried when i was putting the negative battery back on When I put the standard pt cruiser radio back in it worked. Knew i should have un hook the radio .

Is their anyway to see if its just the wiring that was fried? Or if the wiring is fried the whole radio is gone?

If not i will be buying a new deck
Reply With Quote
  #4 (permalink)  
Old 25 Jul 2011, 03:19 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Radio not receiving power?

Pop on down to our Sound and Security section. There's a few guys that hang out there that live and breathe radio stuff.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 PT Cruiser no power to power seat paradyne64 General PT Cruiser Discussions 5 29 Dec 2016 02:54 am
FIXED: No power to power sockets, front or rear InTheBlack Tech & Performance Forum 2 11 Jan 2011 11:12 pm
new radio no power + error code " no fuse " ? Ctown Sound and Security Forum 4 22 Apr 2006 06:03 pm
Stage 1 order date to shipping and receiving? AA PT Stage Turbo Kits 9 12 Sep 2003 03:06 pm


All times are GMT -5. The time now is 11:04 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors