PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Ignition switch or motor mount?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Aug 2011, 02:08 pm
harrym's Avatar
Dedicated Cruiser
 
Join Date: Jul 2011
Location: Missouri Ozarks
Posts: 2,794
Question Ignition switch or motor mount?

I have an '05 Touring non-turbo

Sometimes when I put the transmission into park, I can't turn the ignition switch and remove the key. In order to get the key out, I have to Move the shift lever out of park and then back to park. I have noticed that the problem doesn't occur when I back into the driveway.

When the dealer performed the last oil change, they said that the engine mount was broken. I'm not sure that the ignition is defective or the relay on the shifter, either.

I'm wondering if the replacing the engine mount will solve the problem? Any thoughts?

Hillbilly Harry
Reply With Quote
  #2 (permalink)  
Old 20 Aug 2011, 07:19 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: Ignition switch or motor mount?

Harry, the mount problem is just a run-of-the-mill PT problem that has nothing do do with your car key/Park problem.

PT's have a kind of switch in the shifter mechanism that tells the ignition when you're in Park. So if you're not in Park, you can't remove the keys from the ignition--so some fool doesn't try to remove the keys when you're going down the highway, etc.

Sometimes this safety switch malfunctions. Worst cases involve not being able to get your keys out--at all. You seem not to have come to this point, yet.

Get the sensor/switch fixed before it gets worse.

Tim
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
replacing the mid motor mount Leannaluv Tech & Performance Forum 10 03 Apr 2017 11:01 pm
motor mount cllwyrc Tech & Performance Forum 13 04 Feb 2012 09:02 pm
Motor Mount CityGirl70 Tech & Performance Forum 11 20 May 2011 10:51 pm
Motor Mount Install Mean Green General Turbo Discussions 8 19 May 2011 04:54 pm
Motor mount mod. PVO PT Turbo Wheels/Suspension/Handling 4 28 Jun 2003 02:30 am


All times are GMT -5. The time now is 04:05 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors