PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2009 Pt Cruiser issues

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Sep 2011, 11:24 am
Fresh Cruiser
 
Join Date: Sep 2011
Posts: 1
Default 2009 Pt Cruiser issues

I have a 2009 Pt Cruiser with about 40k miles on it. Over the last few months I have had a couple issues that have not been able to be diagnosed .

1) While driving all the warning lights come on and all the needle go down. When this happens it feels like my car has lost power. It happens miltiple times but only for a second each occurance. If I turn off the car and restart it it typically stops happening.

2) When the AC is on and I am stopped the car acts like it is going to stall. If I turn the AC off it does not attempt to stall.

Can anyone let me know if they have had similar issues and if so what the fix was?

Although this is not my car I found this youtube video showing what my car is doing.


Last edited by ael1220; 17 Sep 2011 at 11:35 am.
Reply With Quote
  #2 (permalink)  
Old 17 Sep 2011, 11:34 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2009 Pt Cruiser issues

It's kind of a newish PT but sounds like two issues. One, the battery cables might be corroded. Take off the air filter and look at the cables to see if any corrosion is around the connections and make sure everything is tight. The loss of power and everything else might be a bad electrical connection or it could be your ignition switch.

Second, it sounds like your fan is not working properly. You have two speeds on the radiator fan and if one isn't working, the conditions you have could be the result.
Reply With Quote
  #3 (permalink)  
Old 17 Sep 2011, 08:20 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: 2009 Pt Cruiser issues

I agree with Crewzin on both issues. I'd also check the battery itself, and connections to the starter (from the battery) for corrosion.

Tim
Reply With Quote
  #4 (permalink)  
Old 19 Sep 2011, 02:14 pm
Young Cruiser
 
Join Date: Mar 2011
Posts: 60
Default Re: 2009 Pt Cruiser issues

I've seen that kind of thing happen on other cars when the battery is bad OR the Alternator is going out. Either way I agree with the previous 2 posts. Check the battery cables, I need to clean corrosion on mine every 6 months.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 PT Cruiser Questions zebek Interior Accessories Forum 1 22 Jun 2011 01:03 pm
2009 radio in 2001 PT cruiser did somebody tried ? Dimitry Interior Accessories Forum 2 14 Jul 2010 02:07 pm
Review: 2009 Chrysler PT Cruiser is a tarnished Golden Oldie PiperGeorge PT Cruiser News and Rumors 7 27 Oct 2009 11:12 am
2009 Dream Cruiser 5 Richard in Idaho General PT Cruiser Discussions 13 25 Mar 2009 09:00 pm
New PT Cruiser model planned for 2009 skylight PT Cruiser News and Rumors 15 30 Aug 2007 03:18 pm


All times are GMT -5. The time now is 03:23 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors