PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Odd MIL light problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Oct 2011, 12:03 pm
Fresh Cruiser
 
Join Date: Nov 2009
Posts: 6
Question Odd MIL light problem

OBED II reader indicates that the MIL light is on, but the light on the day isn't on. I the light shows when the key is in the run position, but turns off when the car is started. Any ideas?

Thank you everyone in advance

Edit*

The only code the computer is throwing is 1648 which I understand to be the code for the battery

Last edited by Ghost; 02 Oct 2011 at 12:14 pm.
Reply With Quote
  #2 (permalink)  
Old 02 Oct 2011, 12:48 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Odd MIL light problem

You don't have a problem, except with your code reader. The engine light is supposed to come on when you turn the ignition on and then go out when the engine starts.

You can clear the battery code by taking off the negative battery cable off for 5 minutes, but your code reader should have the option to clear the computer of that fault, if you know how to use it.
Reply With Quote
  #3 (permalink)  
Old 02 Oct 2011, 12:56 pm
Fresh Cruiser
 
Join Date: Nov 2009
Posts: 6
Default Re: Odd MIL light problem

It stills registers when the codes have been cleared, it won't pass emissions with the MIL light registering
Reply With Quote
  #4 (permalink)  
Old 02 Oct 2011, 01:23 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Odd MIL light problem

If it doesn't clear from taking the battery cable off and still won't clear by using the scanner/code reader, you have a problem with your computer.
Reply With Quote
  #5 (permalink)  
Old 02 Oct 2011, 01:46 pm
Fresh Cruiser
 
Join Date: Nov 2009
Posts: 6
Default Re: Odd MIL light problem

OK thank you very much, guess I get to start playing with electronics next
Reply With Quote
  #6 (permalink)  
Old 02 Oct 2011, 02:51 pm
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Odd MIL light problem

Yes, once you reset via power down, hit the brakes a couple time to bleed off any excess system charge. After that, the code is reset until it reaches 50 indications of that code. Yes, 50. That means you have some tie between genning the code and clearing it to get it inspected. If it's never going away, there is some problem there.
Reply With Quote
  #7 (permalink)  
Old 02 Oct 2011, 03:01 pm
Fresh Cruiser
 
Join Date: Nov 2009
Posts: 6
Default Re: Odd MIL light problem

The 1648 code isn't a failing code according to the sticky, so my next course is to change out the ecu. The from everything I've read I'll have to buy the ecu then take it to a dealer to be programed.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake light problem Cruiserbob General PT Cruiser Discussions 3 10 May 2011 12:27 pm
Brake light problem Shiniquiet General PT Cruiser Discussions 4 24 Sep 2010 07:05 pm
oil light problem HELP DPHC General Turbo Discussions 21 14 Aug 2010 10:46 am
Map light problem + new lights slayerdarkcross Interior Accessories Forum 5 11 Dec 2008 12:04 am
Dome Light Problem Johns Steel Blue General PT Cruiser Discussions 2 21 Aug 2007 07:51 am


All times are GMT -5. The time now is 10:49 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors