PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2005 PT Convertible - HELP!!!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 28 Oct 2011, 10:55 am
Fresh Cruiser
 
Join Date: Oct 2011
Location: North Georgia Mountains
Posts: 3
Thumbs down 2005 PT Convertible - HELP!!!

6 weeks ago, I was going uphill and my car started choking and spitting, acting like it was going to cut off and my engine light came on. Took it to repair shop and was told it was the Cam Shaft sensor which was replaced. Driving home from the repair shop, it did it again. Took it back and they replaced the cam position sensor. Guess what, it happened again. It seems like it does it now after getting gas and then about 2 miles down the road, it starts choking, spitting, etc. If I turn the car off for about 30 mins. this stops but the engine light stays on for exactly 2 days and then it cuts off. Can anyone give me any advice? I cannot remember the code but its the code for the cam shaft sensor. Now they want to take a look at the computer. My car has 185,000 miles on it and it's in pretty good shape (before this happened)!!! I'm afraid it's another sensor and not the computer and not sure about how much money they might extract from me and then only to find out that's not the problem. Any ideas???
Reply With Quote
  #2 (permalink)  
Old 28 Oct 2011, 11:14 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2005 PT Convertible - HELP!!!

Are they using a Camshaft sensor from the Chrysler dealer? Probably not. The after market sensors are CRAP and either don't work at all or don't work for any length of time. Take it back and tell them you want a genuine Chryler/MOPAR sensor ...nothing else will do. Also tell them to check to see that there's no oilin the area where they replace the sensor. that means a seal is leaking from the end of the cam and will ruin any sensor they use.
Reply With Quote
  #3 (permalink)  
Old 28 Oct 2011, 02:05 pm
Fresh Cruiser
 
Join Date: Oct 2011
Location: North Georgia Mountains
Posts: 3
Default Re: 2005 PT Convertible - HELP!!!

Thank you for responding so quickly. I already thought about the repair shop not using the correct sensors from Chrysler. But if that were true, why would it keep doing it after I get gas and then it stops when I turn the car off and then on again. The engine light re-sets after 2 days. Then when I get gas again, this repeats itself. Is there a sensor in the gas tank or something having to do w/the gas not getting to the engine or carberator? I don't know what I'm talking about except the car starts jerking like it's not getting gas........
Reply With Quote
  #4 (permalink)  
Old 28 Oct 2011, 03:50 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: 2005 PT Convertible - HELP!!!

First, find out if they are using the Chrysler genuine part. If not change it and see if your problem goes away. Come back when you find out.
Reply With Quote
  #5 (permalink)  
Old 29 Oct 2011, 06:19 pm
Fresh Cruiser
 
Join Date: Oct 2011
Location: Central California
Posts: 3
Default Re: 2005 PT Convertible - HELP!!!

I was reading through the posts and not to long ago my PT was doing same thing almost. I was going 70 on the freeway and when I sped up to get in left lane it started to jerk and when I hit the pedal it would get worse. After taking it to shop, mine was not a cam shaft sensor but a throttle sensor, I had to drive mine for a couple days before I got it replaced due to money but after it was replaced problem went away, it is possible that its not the cam shaft but see about the throttle position sensor, mine did the same thing and it does it when you hit the gas pedal to speed up.
Reply With Quote
  #6 (permalink)  
Old 29 Oct 2011, 08:19 pm
Young Cruiser
 
Join Date: Oct 2011
Posts: 81
Default Re: 2005 PT Convertible - HELP!!!

Happy it was your TPS and not the Cam sensor, you should think about changing the AIS mounted right next ot the TPS. As both are connected with normal running and performance, you would kill 2 birds with 1 stone. The jerking could also from a gas issue and the delivery pressure that was running at the time? Is your's a turbo unit and if so the fuel has to run about 90psi. I have a 88 Shelby Lancer and had the bucking issue and it was my AIS(automatic Idle Servo(snesor)). When replaced it stopped and I replaced the TPS as well.
Reply With Quote
  #7 (permalink)  
Old 29 Oct 2011, 09:08 pm
Fresh Cruiser
 
Join Date: Oct 2011
Location: Central California
Posts: 3
Default Re: 2005 PT Convertible - HELP!!!

Mine is not a Turbo and right now I am experiencing a loss in mpg, I have lost close to 8 at the moment which I am trying to find the problem and fix to regain the 8 mpg. I had a shop change the TPS but a friend was telling me to have my O2 sensor tested and after what you said I find someone who can test my sensors for me.
Reply With Quote
  #8 (permalink)  
Old 30 Oct 2011, 05:12 pm
Fresh Cruiser
 
Join Date: Oct 2011
Location: North Georgia Mountains
Posts: 3
Default Re: 2005 PT Convertible - HELP!!!

Thank you for the replies. I will take the car back to my mechanic w/these ideas. My car is not a turbo either but the symptoms are exactly as you mentioned.....starts jerking when I hit the gas pedal. Thanks again and I hope this helps my problem.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 convertible problem DC1327 PT Cruiser Convertible Forum 6 21 Dec 2013 11:26 pm
FS 2005 GT Convertible fljohnboy Classifieds: For Sale/Trade 10 13 Jun 2013 10:07 pm
2005 GT H.O. Turbo Convertible spotman Welcome New PT Cruiser Members 4 28 Aug 2011 04:07 pm
2005 2005 Convertible top/drivers windows not working rabidaardvark PT Cruiser Convertible Forum 6 08 Sep 2010 10:48 pm
2005 convertible Halo Tech & Performance Forum 0 26 Aug 2010 07:51 pm


All times are GMT -5. The time now is 02:36 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors