PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Engine light is on, car hesitates/sputters when trying to accelerate past 30 mph..

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Nov 2011, 10:01 pm
Fresh Cruiser
 
Join Date: Oct 2010
Posts: 19
Default Engine light is on, car hesitates/sputters when trying to accelerate past 30 mph..

Hello,

Once again I have an issue with my car...The other day my engine light came on, my mom and I checked the gas cap and made sure everything was fine under the hood and after a while the light went away. Well tonight on our way home the light came back on and when I was stopped and accelerated the car started jerking a little and hesitated to go and I noticed it's when I try to go past 30 mph..it was really scary. My grandfather is taking the car to have it looked at tomorrow but has anyone else had a problem similar to this? I really hope it's nothing extremely major..this would have to happen at this time when I don't have any money to fix my car..

Forgot to add that my mom and grandpa thinks it might be the O2 sensor or something but I'm worried it could be something else more serious...my car is a 2006 with a little over 43,000 miles on it. Thanks for any advice.

Last edited by quietcharm23; 02 Nov 2011 at 10:04 pm.
Reply With Quote
  #2 (permalink)  
Old 03 Nov 2011, 12:09 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Engine light is on, car hesitates/sputters when trying to accelerate past 30 mph.

If the engine light came on, the computer should have a fault code stored in memory. We need that code to help us help you. Here's instructions on how to get that code.

How to retrieve fault codes.
Reply With Quote
  #3 (permalink)  
Old 03 Nov 2011, 09:42 am
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: Engine light is on, car hesitates/sputters when trying to accelerate past 30 mph.

check the codes like crewzin says but it sounds like the cam sensor it is a easy fix the only down side is you need to use a True Mopar sensor from the dealer---yes they sell aftermarket ones rom auto parts stores but the PT usally will not like the aftermarket ones its about a $50 part and is less than 10 minutes to put it in
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Engine misfire and flashing check engine light fg1911a1 General Turbo Discussions 15 26 Jul 2014 06:20 pm
Cruiser Hesitates at Stop Light/Sign caballero77 Tech & Performance Forum 34 06 Oct 2011 12:06 pm
Check engine light: Amber Light: power loss dbleclk Turbo Performance 2 06 Jul 2011 06:12 am
05 doesnt like to start then sputters bucks NO check engine light on??? racyred426 Tech & Performance Forum 0 16 Apr 2011 09:24 am
Engine going past redline. PTucker Tech & Performance Forum 10 06 Nov 2003 12:42 am


All times are GMT -5. The time now is 04:48 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors