PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Please help!!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Nov 2011, 06:40 pm
Fresh Cruiser
 
Join Date: Nov 2011
Posts: 2
Default Please help!!

I'm ready to explode. 2001 pt, motor trash, put in 2003 engine. I get conflicting information that it won't work. some say it will. Car won't start. 2001 computer won't read 2003 engine sensors. Is that true? Am I screwed? Can you swap in a 2003 motor into 2001 without having to change computer and engine wiring harness?

Last edited by fireinferno; 03 Nov 2011 at 06:44 pm.
Reply With Quote
  #2 (permalink)  
Old 03 Nov 2011, 08:47 pm
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,324
Default Re: Please help!!

Now I'm not sure about this, but I think I remember reading about this on PTCrew, that if you swap the engine you have to have or ECM reprogrammed. I'm no expert, especially on pre-'06 models, but I think that sounds logical.
Reply With Quote
  #3 (permalink)  
Old 04 Nov 2011, 04:36 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: Please help!!

Is crank sensor behind starter or above oil filter?
Reply With Quote
  #4 (permalink)  
Old 06 Nov 2011, 10:39 am
Fresh Cruiser
 
Join Date: Nov 2011
Posts: 2
Default Re: Please help!!

It's above oil filter. In 2003, they moved it to front of car. That's the only difference.
Reply With Quote
  #5 (permalink)  
Old 06 Nov 2011, 11:34 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Please help!!

I think the EGR pipe in the back of the upper manifold is different. I believe Chrysler re-engineered something and did away with the pipe altogether in 2003. Before that, the EGR pipe goes from the back of the upper manifold down to the EGR valve.

Reply With Quote
  #6 (permalink)  
Old 06 Nov 2011, 11:41 am
Cool Cruiser
 
Join Date: Dec 2010
Location: Northumberland PA
Posts: 261
Default Re: Please help!!

thats correct because i believe after 03 it went to driver side of the engine. and with doing work to my pt last night the upper intake manifold still has the whole there for the egr valve to bolt in.
Reply With Quote
  #7 (permalink)  
Old 06 Nov 2011, 02:30 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: Please help!!

Quote:
Originally Posted by fireinferno View Post
It's above oil filter. In 2003, they moved it to front of car. That's the only difference.
So the engine you had had the crank sensor above the filter,

The CURRENT engine has it behind the starter? Correct?

You've put a NGC engine in place of a non NGC engine.

Don't think that's going to work.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:46 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors