PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
crankshaft sensor stuck

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Nov 2011, 10:28 pm
Fresh Cruiser
 
Join Date: Nov 2011
Posts: 4
Default crankshaft sensor stuck

I have an 03 Cruiser with the sensor below the starter.
I have removed the 8mm bolt but the sensor will only rotate but not budge.

I have seen one other post on here with the same problem but no fix. I hear the o ring rusts in. Anyone have any ideas?

Thanks!
Reply With Quote
  #2 (permalink)  
Old 16 Nov 2011, 01:15 am
jdpersico's Avatar
Young Cruiser
 
Join Date: Jul 2011
Location: Ann Arbor, MI
Posts: 61
Default Re: crankshaft sensor stuck

did you tried to do a little leverage with a screwdriver?
is pretty uncomfortable to work in there, sometimes you just can't make enough force.
Reply With Quote
  #3 (permalink)  
Old 16 Nov 2011, 11:14 am
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: crankshaft sensor stuck

You are correct this is a problem, what happens:
area outside of sensor seal gets rusty.
Exactly same as Neons, except their sensor would break off

You have no choice except to pull and twist simultaneously.
It will likely come out, I've done a few.
Reply With Quote
  #4 (permalink)  
Old 16 Nov 2011, 11:46 pm
Fresh Cruiser
 
Join Date: Nov 2011
Posts: 4
Default Re: crankshaft sensor stuck

Thanks guys, i have pried with a screwdriver until it almost snapped off.
I am going to remove the starter tomorrow and see if i can go in from the top.
Problem is that it is stick shift and the clutch slave is in the way.

I guess worst scenario the plastic will snap off and i can dig the rest of it out somehow.
Reply With Quote
  #5 (permalink)  
Old 17 Nov 2011, 03:48 am
Regular Cruiser
 
Join Date: Jul 2010
Location: El cajon(san diego county), California
Posts: 191
Send a message via AIM to srebik Send a message via MSN to srebik
Default Re: crankshaft sensor stuck

what about trying a penetrating oil like pb blaster?

soaking it real good and letting it sit then spray again and work your sensor again.

if the outside part of it is rusting maybe you can get around it with a pick or small screw driving and remove some of the adhereing rust.

or maybe pry is a couple of different areas to try and loosen it up.
__________________

2003 Dark Blue Non-Turbo Pt Cruiser w/ 5 speed
Reply With Quote
  #6 (permalink)  
Old 17 Nov 2011, 08:42 am
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: crankshaft sensor stuck

Problem is is that rust is deep in bore, certainly PB's not going to hurt anything!
I know the newer sensors have much thinner plastic than the old ones.
You can hunt down the engineer later and ... thank him???
Reply With Quote
  #7 (permalink)  
Old 20 Nov 2011, 12:13 am
Fresh Cruiser
 
Join Date: Nov 2011
Posts: 4
Default Re: crankshaft sensor stuck

Thanks for the help guys. Had to remove the starter and battery tray. much better access to pry it out from the top . It took about 10 mins and pb blaster to pry it out.There was no way it was coming out from underneath as there is no leverage points. New one is installed .
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
crankshaft position sensor ab33arch Tech & Performance Forum 23 31 Mar 2017 04:13 pm
CrankShaft Sensor/CamShaft Sensor Questions PTMomma Tech & Performance Forum 8 12 Aug 2014 01:43 pm
Crankshaft Position Sensor Replaced But.. SuperTroy General PT Cruiser Discussions 10 01 Jan 2013 06:20 pm
Where is the crankshaft sensor? barry8108 Tech & Performance Forum 2 08 Dec 2010 06:24 pm
HELP! Crankshaft pos sensor won't come out! reluctantlycrouched Tech & Performance Forum 0 09 Jul 2010 08:33 pm


All times are GMT -5. The time now is 12:47 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors