PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
07 pt cruiser no spark or injector pulse

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12 Jan 2012, 02:48 pm
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 6
Default 07 pt cruiser no spark or injector pulse

good day everyone. ok here goes, i have an 07 cruiser 2.4 non turbo, i have no spark or injector pulse. on my solus scanner as i crank it it shows cam and crank sensor in sync but a 9 or so degree difference. does mean the timing belt has slipped and causing my woes? i thought that until i checked and it looks to be in time. no dtc's whatever. check and verified asd relay is working correctly. all fuses are good. i unplugged all sensors, injectors and coil and receive a dtc for all. plug all back in one by one and the dtc's go away. any ideas would be helpful. thanks in advance
Reply With Quote
  #2 (permalink)  
Old 13 Jan 2012, 09:30 am
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 6
Default Re: 07 pt cruiser no spark or injector pulse

anybody?
Reply With Quote
  #3 (permalink)  
Old 13 Jan 2012, 10:02 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default Re: 07 pt cruiser no spark or injector pulse

Over 40 people looked at your problem but I guess, like me, are as stumped as you are. The only thing I can suggest is that the Camshaft or Crankshaft sensor might be a problem. They both work in telling the computer when to send spark from the coil to the plugs. You can crank the ignition all day but if one of them is bad, no spark.

http://forums.bimmerforums.com/forum...d.php?t=971792

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.

Last edited by CREWZIN; 13 Jan 2012 at 10:05 am.
Reply With Quote
  #4 (permalink)  
Old 13 Jan 2012, 10:41 am
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 6
Default Re: 07 pt cruiser no spark or injector pulse

have verified both are sending signals to the pcm. looks like a pcm will have to be ordered. thanks everyone
Reply With Quote
  #5 (permalink)  
Old 13 Jan 2012, 11:02 am
RaineMan's Avatar
Cool Cruiser
 
Join Date: Aug 2010
Location: SL,UT
Posts: 271
Default Re: 07 pt cruiser no spark or injector pulse

Quote:
Originally Posted by CREWZIN View Post
Over 40 people looked at your problem but I guess, like me, are as stumped as you are. The only thing I can suggest is that the Camshaft or Crankshaft sensor might be a problem. They both work in telling the computer when to send spark from the coil to the plugs. You can crank the ignition all day but if one of them is bad, no spark.
Yeah... I was thinking cam positioning sensor myself. Those things are known for going bad.

Even if your timing was off you would still be getting spark and fuel pulses... they would just not be synched properly. I would venture a guess that a complete failure is something electrical related.
Reply With Quote
  #6 (permalink)  
Old 13 Jan 2012, 11:02 am
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: 07 pt cruiser no spark or injector pulse

Quote:
Originally Posted by lilblkshp View Post
07 cruiser 2.4 non turbo
no spark or injector pulse.
scanner as i crank it it shows cam and crank sensor in sync but a 9 or so degree difference.
I'd ask why it's in synch but 9 degrees out. This contradicts.
You'd need to find TDC then pull upper timing cover and verify cam alignment.
On Neon, cam misalignment will turn off ASD.
It will run on all but one year w/o cam sensor, dunno about PT.
Reply With Quote
  #7 (permalink)  
Old 13 Jan 2012, 11:16 am
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 6
Default Re: 07 pt cruiser no spark or injector pulse

quick question, when the asd relay energizes the middle wire on the coil should the power be feeding back to the pcm thru the coil 1 and coil 2 wires?
Reply With Quote
  #8 (permalink)  
Old 13 Jan 2012, 04:20 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default Re: 07 pt cruiser no spark or injector pulse

Hope somebody comes along and answers your question. It's way over my head. The Haynes and Chilton manuals have schematics but doesn't get that deep into the whole system.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #9 (permalink)  
Old 13 Jan 2012, 06:13 pm
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 6
Default Re: 07 pt cruiser no spark or injector pulse

thanks alot anyway. i think the pcm is toast, but its not affecting anything else
Reply With Quote
  #10 (permalink)  
Old 13 Jan 2012, 07:09 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: 07 pt cruiser no spark or injector pulse

This is from Neon experience;

Center wire is positive from ASD (Sounds like you already know this)
other two wires are grounded by PCM as needed for spark- It's 'wasted spark' or 'batch fire' not sequential (why there's only two ground wires)

IF cam and crank are far enough out of synch, PCM won't turn on ASD.
THE FSM would have that specific number, IOW, would 9 degrees be enough to disable ASD.

There's an initial ASD to prime fuel pump, but it stops until cranking.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Injector question OurPTGT Tech & Performance Forum 1 11 Dec 2011 08:10 pm
01. pt cruiser no spark gjason49 Tech & Performance Forum 1 03 Jul 2011 04:08 pm
Help no spark 2002 pt cruiser zackkbcobra Tech & Performance Forum 14 27 Jun 2011 03:27 pm
injector question? 03greygtcruiser Stage Turbo Kits 3 13 May 2008 09:46 pm
Fuel Injector American flyer Tech & Performance Forum 7 14 Jan 2003 12:56 pm


All times are GMT -5. The time now is 09:39 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors