PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
where do I start to fix

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10 Feb 2012, 06:36 pm
brvalleygirl30's Avatar
Fresh Cruiser
 
Join Date: Feb 2012
Posts: 1
Default where do I start to fix

I have an 08 pt cruiser base model. two days ago it started bucking while going about 60. the check engine came one. the next day the engine light went off. Later on in the day it started bucking again (kind of like the back breaks where grabbing). The engine never died, we dropped the mph and the car ran fine. At auto zone they gave us the code P0340. Reading the forum I haven't made any formal decision on what the problem is whether it be the sensor its self or the wiring or a loose connection. I have found out where the sensor sits and how long it should take to replace the sensor. The car still runs, still cranks. So please can someone give me a clear picture of where to start.
Reply With Quote
  #2 (permalink)  
Old 10 Feb 2012, 06:41 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default Re: where do I start to fix

You already know WHERE to start ....the Camshaft Position sensor. First take off the electrical connection and inspect it for anything unusual. Next, follow the wiring harness all the way around back of the engine. Mine came loose and hung low enough to hit the spinning half shaft on the passenger side. Inspect where it goes around the corner of the engine and as far along the back as possible for any breaks in the harness. If all looks good, pick up a new sensor at the dealer. Don't buy one from an auto store even though it will be a little cheaper. After market parts are made out of junk. Even if it works, it won't last long. Stick with a genuine MOPAR part.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Car will not start when Hot Berthold Tech & Performance Forum 6 30 Jul 2015 08:48 pm
won't start lemonee Welcome New PT Cruiser Members 3 25 Nov 2011 02:31 pm
PT won't start veracruise Tech & Performance Forum 22 02 Sep 2011 04:23 pm
car didn't start in the cold, got jumped then was a bubbling sound and won't start Saqqara Tech & Performance Forum 1 15 Dec 2009 06:35 am
What a way to start the day!! Knotsobright1 General PT Cruiser Discussions 7 06 Oct 2009 12:00 am


All times are GMT -5. The time now is 07:26 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors