PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
I have a 2002 touring edition.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Feb 2012, 12:53 pm
Fresh Cruiser
 
Join Date: Feb 2012
Posts: 3
Default I have a 2002 touring edition.

Ok so we changed out my hub bearing, new brakes and new roders but still have a rubbing sound in front passanger tire. Anyone have any idea? I know I need an alinement but could that cause rubbing. It only makes the rubbing sound when I push on my brakes.
Reply With Quote
  #2 (permalink)  
Old 13 Feb 2012, 01:11 pm
Koch's Avatar
Cool Cruiser
 
Join Date: Feb 2012
Location: Salyersville, ky
Posts: 213
Default Re: I have a 2002 touring edition.

Quote:
Originally Posted by Tash27 View Post
Ok so we changed out my hub bearing, new brakes and new roders but still have a rubbing sound in front passanger tire. Anyone have any idea? I know I need an alinement but could that cause rubbing. It only makes the rubbing sound when I push on my brakes.
you might have a caliper sticking, a bad brake hose can cause this also
Reply With Quote
  #3 (permalink)  
Old 13 Feb 2012, 01:40 pm
Fresh Cruiser
 
Join Date: Feb 2012
Posts: 3
Default Re: I have a 2002 touring edition.

I didnt even think about that. Thank you! Ill get that checked.
Reply With Quote
  #4 (permalink)  
Old 26 Feb 2012, 02:39 am
Fresh Cruiser
 
Join Date: Feb 2012
Posts: 3
Default Re: I have a 2002 touring edition.

Well I found out it's actually my roders and my struts. But my pt is losing some coolant. New water pump so I don't know what it could be. I know I have to change my intake gaskets. Could that cause coolant to leak?
Reply With Quote
  #5 (permalink)  
Old 26 Feb 2012, 10:29 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,901
Smile Re: I have a 2002 touring edition.

Quote:
Originally Posted by Tash27 View Post
Well I found out it's actually my roders and my struts. But my pt is losing some coolant. New water pump so I don't know what it could be. I know I have to change my intake gaskets. Could that cause coolant to leak?
No the intake is not involved. Check the thermostat housing and the radiator cap. Check hoses where they connect and the radiator. I have seen the metal pipe that goes into the water pump (on the front of the motor) rust and leak were it goes into the block. The lower hose connects to this.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 PT Cruiser Touring Edition Saphyre General PT Cruiser Discussions 3 28 Jun 2011 09:56 am
Buy My 2002 Red PT Cruiser Touring Edition - please! thinkinboutit Classifieds: For Sale/Trade 3 28 May 2011 12:25 pm
2002 Touring Edition, For Sale Dan_in_Savannah Classifieds: For Sale/Trade 6 26 Oct 2007 03:07 pm
2002 touring edition gone THier General PT Cruiser Discussions 6 06 Jul 2003 11:50 pm


All times are GMT -5. The time now is 07:28 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors