PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
A/C issue and Tie Rod ?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 20 Feb 2012, 08:11 am
themadgreek187's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: Jax FL
Posts: 104
Default A/C issue and Tie Rod ?

First off my neighbor(certified mechanic) has always worked on my car. he knows pretty much everything on my car. this weekend we tried to replace the front tie rods and apparently u need a special tool of some sort to remove the tie rods? any ideas?

2nd my a/c has stopped working. the compressor does not kick on nor does the fan.fan was replaced not even a year ago. we found that the socket that plugs into the switch on the back of the compressor does not seem to work. he can jump the switch by grounding it which causes everything to turn on. i am guessing the socket or wire is bad. tried looking up replacement parts but no avail. any ideas?
Reply With Quote
  #2 (permalink)  
Old 20 Feb 2012, 08:28 am
Dedicated Cruiser
 
Join Date: Mar 2011
Posts: 2,943
Default Re: A/C issue and Tie Rod ?

For the inner tie rods you need to use this tool.

Lisle Inner Tie Rod Tool | Wayfair
Reply With Quote
  #3 (permalink)  
Old 20 Feb 2012, 09:13 am
themadgreek187's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: Jax FL
Posts: 104
Default Re: A/C issue and Tie Rod ?

thanks i appreciate it. i wonder if u can buy that locally? oreillys , autozone, etc
Reply With Quote
  #4 (permalink)  
Old 20 Feb 2012, 12:48 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,901
Default Re: A/C issue and Tie Rod ?

Quote:
Originally Posted by themadgreek187 View Post
First off my neighbor(certified mechanic) has always worked on my car. he knows pretty much everything on my car. this weekend we tried to replace the front tie rods and apparently u need a special tool of some sort to remove the tie rods? any ideas?

2nd my a/c has stopped working. the compressor does not kick on nor does the fan.fan was replaced not even a year ago. we found that the socket that plugs into the switch on the back of the compressor does not seem to work. he can jump the switch by grounding it which causes everything to turn on. i am guessing the socket or wire is bad. tried looking up replacement parts but no avail. any ideas?
Outer tie rods, any body with mechanical ability can change. Inners requires a a special tool available at the parts store. Maybe can rent. On the ac did you check to see if the freon leaked out?
Reply With Quote
  #5 (permalink)  
Old 20 Feb 2012, 04:20 pm
themadgreek187's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: Jax FL
Posts: 104
Default Re: A/C issue and Tie Rod ?

a/c freon has not leaked. apparently the wire connecting to the HPS must have a bad ground. he is going to see about bypassing the bad ground and just running a new wire altogether. called the Chrysler dealership and their suggestion was too buy new harness for the wiring but replacing that would be a PITA and $$$$$. car has 175k and i'm not dumping much more into it.
Reply With Quote
  #6 (permalink)  
Old 20 Feb 2012, 04:53 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,901
Default Re: A/C issue and Tie Rod ?

Quote:
Originally Posted by themadgreek187 View Post
a/c freon has not leaked. apparently the wire connecting to the HPS must have a bad ground. he is going to see about bypassing the bad ground and just running a new wire altogether. called the Chrysler dealership and their suggestion was too buy new harness for the wiring but replacing that would be a PITA and $$$$$. car has 175k and i'm not dumping much more into it.
Don't blame ya on the harness. Might go through all the chasey grounds in engine bay. Think there is some under the battery, I think. Bet there is a ground location schematic in this forum somewhere. Its got everything else! If your not getting ground there it will show up somewhere else later.
Reply With Quote
  #7 (permalink)  
Old 23 Feb 2012, 08:44 am
themadgreek187's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: Jax FL
Posts: 104
Default Re: A/C issue and Tie Rod ?

ok got the tie rods done and the car aligned. drives like brand new! now my AC issue. it appears there may be a short in the wire plugging into the High Pressure switch on the compressor. my mechanic can bypass the wire but the AC will run continuously and that won't be good. any other tricks to try as i don't wanna shell out a ton of money?
Reply With Quote
  #8 (permalink)  
Old 02 Mar 2012, 02:07 pm
themadgreek187's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: Jax FL
Posts: 104
Default Re: A/C issue and Tie Rod ?

so update to my a/c issue. seems as though they are thinking my wiring harness is bad. thats $1000 im not throwing into this car. i'm cutting my losses and buying a new car. my pt has served me well since 05. too many issues down the stretch. thanks for all on here who provide useful information.
Reply With Quote
  #9 (permalink)  
Old 02 Mar 2012, 06:25 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,901
Default Re: A/C issue and Tie Rod ?

Quote:
Originally Posted by themadgreek187 View Post
so update to my a/c issue. seems as though they are thinking my wiring harness is bad. thats $1000 im not throwing into this car. i'm cutting my losses and buying a new car. my pt has served me well since 05. too many issues down the stretch. thanks for all on here who provide useful information.
Good luck with the new ride!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just a little issue with my PT... TheDarkAvengerX General PT Cruiser Discussions 8 03 Nov 2011 04:55 pm
Key Fob issue Motherlynn Tech & Performance Forum 22 17 Feb 2011 04:41 pm
03 GT AC issue freakengine Tech & Performance Forum 5 04 Sep 2010 10:06 pm
HID issue CYCLONE_06 Tech & Performance Forum 0 16 Apr 2009 08:00 pm
A/C issue. hermtm2 General PT Cruiser Discussions 9 26 Jul 2008 08:40 pm


All times are GMT -5. The time now is 12:36 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors