PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Engine rock and squeak, not torque mounts??

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06 Mar 2012, 03:40 pm
Fresh Cruiser
 
Join Date: Feb 2012
Posts: 7
Default Engine rock and squeak, not torque mounts??

Just replaced my torque mounts the other day. I had been experiencing a lot of engine rock, as well as some sporadic squeak on startup and takeoff. The torque mounts didn't want to adjust at all, the whole car just lifted when jacking the front of the engine with all bolts loose. I tightened everything down while it was jacked up, figured it was better than nothing.

After new torque mounts engine rock has reduced and vibration increased alot, pretty standard. However, I am still experiencing a degree of rocking as well as the squeak. The rocking is noticeable on shift 2nd-3rd gear and sometimes 3rd-4th. Transmission fluid and filter were just changed in the last 1k. I know that the control arm bushings are going, which could be where the squeaking is coming from.

What else would cause rocking?
Reply With Quote
  #2 (permalink)  
Old 06 Mar 2012, 08:56 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,912
Default Re: Engine rock and squeak, not torque mounts??

Geez- don't know. Not a loose alternator belt squeaking.

How do you know it's rocking?
You can drive with hood off or something?
Reply With Quote
  #3 (permalink)  
Old 06 Mar 2012, 09:08 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,901
Default Re: Engine rock and squeak, not torque mounts??

Quote:
Originally Posted by UptownSport View Post
Geez- don't know. Not a loose alternator belt squeaking.

How do you know it's rocking?
You can drive with hood off or something?
Did you check your tie rods & ball joints? This might account for the rocking. If you don't get the adjustment on the mounts close its going to vibrate. Really need to try this again.
Reply With Quote
  #4 (permalink)  
Old 07 Mar 2012, 08:07 pm
Fresh Cruiser
 
Join Date: Feb 2012
Posts: 7
Default Re: Engine rock and squeak, not torque mounts??

Fixed the rocking.. Turns out that the transmission was overfilled by a good quart or so, must have been causing some rough shifting.
Squeaking is coming from drivers side. It goes away if I apply about 10-20lbs of pressure to the transmission pan.

Do the transmissions ever have mount issues? What else would make a metal-on-metal kind of squeak on the drivers side?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Upper & Lower Motor Mounts (Torque Struts) 808 Classifieds: For Sale/Trade 18 10 Jul 2012 10:30 pm
engine mounts lt4supr Turbo Performance 25 05 Oct 2011 01:19 pm
performance motor and tramision mounts and "torque struts" srebik Tech & Performance Forum 3 31 Jul 2010 01:51 am
engine mounts lt4supr General PT Cruiser Discussions 11 04 Jun 2008 07:56 am
Engine mounts KingKole02 Tech & Performance Forum 3 13 Jan 2005 04:04 pm


All times are GMT -5. The time now is 08:10 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors