PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Crankcase sensor /Camshaft sensor

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08 Mar 2012, 11:29 am
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 24
Default Crankcase sensor /Camshaft sensor

Ok, have a problem with my 2000 Cruiser 2.0
The fault code flashed up on the odometer and leads to say that it is the crankcase sensor, but the code i saw was P0320 - local UK garage says that is Crankcase, your list on here says something else...

So, could someone point me ni the direction of a Crankcase sensor thread for repalcement method....

I coudl also replace the camshaft sensor - worth it?

If i have been in and around the camshaft area in the last 2 weeks (replacing PCV hose) is there a chance i have knocked it? and justa tap might work?
Reply With Quote
  #2 (permalink)  
Old 08 Mar 2012, 11:46 am
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 24
Default Re: Crankcase sensor /Camshaft sensor

update, i have just foudn on here how to get teh fault codes out again, so will check them again first before buying parts...
Reply With Quote
  #3 (permalink)  
Old 08 Mar 2012, 11:48 am
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,918
Default Re: Crankcase sensor /Camshaft sensor

I'm not sure you or them are saying anything different.
You can just google the code, they are standardized-

The sensor isn't fun to change, the bore outboard of the sensor's o-ring rusts, and it becomes very difficult to remove.
Reply With Quote
  #4 (permalink)  
Old 08 Mar 2012, 01:25 pm
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 24
Default Re: Crankcase sensor /Camshaft sensor

OK,
Just managed to pull off the codes:
P1684 - I found on the forum that basically a hard reset (negative off for 30 secs) will reset this.
P0320 - found Crewzin explaining that this is linked to the CRankcase sensor, or just the wiring maybe...

So, i need to know where I'm looking for the CRankcase sensor.

the fault did seem intermittent, it would start and run fine, then have a funny turn, then start and run fine again - mayeb a hard reset first call to check might work?
Reply With Quote
  #5 (permalink)  
Old 08 Mar 2012, 02:08 pm
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 24
Default Re: Crankcase sensor /Camshaft sensor

Latest update, just done the hard reset and now am just getting P1684 (due to the reset)

so I am guessing good to test now.

If the crankcase sensor was faulty, woudl it be dead dead, ie not start once its stopped - or would it be intermittent? or woudl it be in limp mode?

Basically i was driving along and then it just died, then started again all fine up to 4500rpm and all fine, then then it woudl just die off again, then wait and start and go again it basically beat me when teh battery had died from all the restarts.

loose connection maybe, but when it wouldn't start it wouldnt start for like 5 goes and then randomly it would.

a bug in the computer maybe?
Reply With Quote
  #6 (permalink)  
Old 08 Mar 2012, 03:43 pm
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 24
Default Re: Crankcase sensor /Camshaft sensor

Ok, test run didn't go too well..LOL

took 1 hour of 10 min resets to get her back.

one extra code that came up was 1391 - which from Chrysler PT Cruiser computer codes says can;t see crank sensor signal. and ties up with 0320 being the crank sensor.

so, I have read in the past few threads that rust can be a problem, and that people have removed the Starter (how?! where is this?) and teh battery tray to get easier leverage on the thing...

so Battery out, starter out and then replace - ince part is sourced!

am i in the right area?
Reply With Quote
  #7 (permalink)  
Old 08 Mar 2012, 05:25 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,918
Default Re: Crankcase sensor /Camshaft sensor

Your getting confusing information- one is for the CAM sensor, and the other the LATE MODEL CRANK sensor.

Your CRANK sensor is above the oil filter.
Reply With Quote
  #8 (permalink)  
Old 09 Mar 2012, 04:11 am
Fresh Cruiser
 
Join Date: Jan 2012
Posts: 24
Default Re: Crankcase sensor /Camshaft sensor

SO basically it is the CRank sensor then?

woudl the problem be intermittent though, or does that point to a wiring problem?
Reply With Quote
  #9 (permalink)  
Old 09 Mar 2012, 11:23 am
Fresh Cruiser
 
Join Date: Jul 2008
Posts: 8
Default Re: Crankcase sensor /Camshaft sensor

I'm having this same issue. Car will die while going down the road and will start back up again after a few minutes. I am also getting the 0320 code. My crank and cam sensors were replaced a little over a year ago so I am thinking it may be the wires. I haven't had a chance to get under there and look since it is dark by the time I get home from work. I will check it out tomorrow as I am off of work. Keep us posted and I will do the same.
Reply With Quote
  #10 (permalink)  
Old 09 Mar 2012, 01:26 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,918
Default Re: Crankcase sensor /Camshaft sensor

Sure could be either-

There's been lots of problems reported with aftermarket sensors, get a dealer on or Standard Motor Product NON "T" series
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CrankShaft Sensor/CamShaft Sensor Questions PTMomma Tech & Performance Forum 8 12 Aug 2014 01:43 pm
Camshaft sensor (again!) ABrown Tech & Performance Forum 21 29 Mar 2012 03:31 pm
Camshaft Position Sensor ejschultz Tech & Performance Forum 6 22 Sep 2010 09:58 pm
Camshaft Position Sensor kghaddon Tech & Performance Forum 5 02 Jun 2009 10:09 am
Camshaft Sensor ABrown General PT Cruiser Discussions 2 18 Jun 2008 07:36 am


All times are GMT -5. The time now is 05:45 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors