PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Keep breaking strut mount.....

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Mar 2012, 07:08 pm
Fresh Cruiser
 
Join Date: Mar 2012
Location: New york
Posts: 3
Default Keep breaking strut mount.....

Background:
2002 dream cruiser, new eibach drop, kyb all four corners.
New lower control arms, new inner and outer tie rods, new front wheel bearings and hubs.
Perfect alignment, all four wheels balance perfect.
Fd strut brace installed.

Here is my issue....
I have a very bad shake in the steering wheel between about 47 and 80 mph. I have tried three sets of rims/ tires and it doesn't change. I have also broken two new strut mounts on the right front strut in the last 1000 miles. And I just noticed yesterday that the right lower motor mount I replaced while out doing the lca is also now broken!

I saw a post somewhere on here where there is a way to align the strut mounts, is this what may be causing all my grief?, and how is it done? I searched to no avail on here, I am new so don't flame me please if there is info on here I somehow missed!

Any help at all would be awesome as I am at a point where I am getting tired of taking the strut on and off!!!!
And thank you!!!
Reply With Quote
  #2 (permalink)  
Old 17 Mar 2012, 09:18 pm
mdfrodolives's Avatar
Senior Cruiser
 
Join Date: May 2010
Posts: 1,313
Default Re: Keep breaking strut mount.....

There is an active topic in this section of the forum as we speak. It's called "Changed Motor Mounts Engine Shakes".

Check it out. All three pages ....

However, if you're actually breaking your motor struts, then I'd bet on a broken center motor mount.

Tim
Reply With Quote
  #3 (permalink)  
Old 17 Mar 2012, 09:44 pm
Fresh Cruiser
 
Join Date: Mar 2012
Location: New york
Posts: 3
Default Re: Keep breaking strut mount.....

The motor mount was just a side note. After reading some more on here I think it may be due to the fact that it's an anchor. My main concern is the upper strut mount on the suspension.
Reply With Quote
  #4 (permalink)  
Old 17 Mar 2012, 09:57 pm
Fresh Cruiser
 
Join Date: Mar 2012
Location: New york
Posts: 3
Default Re: Keep breaking strut mount.....

Oh yeah and the motor mount that is breaking is the pencil strut.
Reply With Quote
  #5 (permalink)  
Old 17 Mar 2012, 10:03 pm
Dedicated Cruiser
 
Join Date: Mar 2011
Posts: 2,943
Default Re: Keep breaking strut mount.....

I had a problem with a strut mount too. The white plastic bearing was breaking because I installed it wrong.

BTW, what part of NY?
Reply With Quote
  #6 (permalink)  
Old 17 Mar 2012, 11:00 pm
Goldreamer's Avatar
Fresh Cruiser
 
Join Date: Feb 2011
Location: San Jose Ca
Posts: 46
Default Re: Keep breaking strut mount.....

I have replace the upper and lower motor mounts on my car four times. The forth time I replace the upper motor mount, the center motor mount, lower mount and the transmission mount. Took me and friend about 5 hours to replace the center motor mount.It was a pain, a get a headache just thinking about it. I would suggest to replace all four at the same time it will definitely help. If you havent replace the timing belt, the tensioner, and the water pump and the other belts might as well do it when replacing the center mount
Reply With Quote
  #7 (permalink)  
Old 18 Mar 2012, 12:53 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,851
Default Re: Keep breaking strut mount.....

Quote:
Originally Posted by Goldreamer View Post
I have replace the upper and lower motor mounts on my car four times. The forth time I replace the upper motor mount, the center motor mount, lower mount and the transmission mount. Took me and friend about 5 hours to replace the center motor mount.It was a pain, a get a headache just thinking about it. I would suggest to replace all four at the same time it will definitely help. If you havent replace the timing belt, the tensioner, and the water pump and the other belts might as well do it when replacing the center mount
I think they are talking about the shock (strut) upper bearing. I know to many struts to keep up with.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing Upper Torque Strut/Mount paulrosenthal Wheels, Tires, Suspension 9 11 Jun 2011 03:21 pm
Motor Mount (upper strut) bolts. mdfrodolives Tech & Performance Forum 12 07 May 2011 02:12 am
Lug nuts breaking kirbykit Wheels, Tires, Suspension 8 26 Aug 2010 09:09 pm
No Power Steering while breaking Msknow Tech & Performance Forum 2 09 Jul 2010 12:47 pm
AIR BOX TABS BREAKING littleblueGT Turbo Performance 4 23 May 2005 06:45 pm


All times are GMT -5. The time now is 01:45 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors