PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2008 - 2.4 owners

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 30 Apr 2012, 07:20 pm
Cool Cruiser
 
Join Date: May 2011
Posts: 228
Default 2008 - 2.4 owners

Well, I have been having fits but cant imagine its true. Recently plagued with rough idle and misfire issues I bought a Haynes repair manual. Ummm, my EGR valve isnt where they say, I dont see any exhaust connection or tube to the upper intake manifold. Also I cant find the MAP sensor, it also is not where they say it is. So, is the Haynes wrong, or was mine removed? I see a shiny brass plug where the tube to the upper intake should be! Can anybody shed some light on this?
Reply With Quote
  #2 (permalink)  
Old 30 Apr 2012, 07:31 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: 2008 - 2.4 owners

Only the first two years had the EGR valve and the tube that ran down the back of the upper manifold. I have 3 manuals, (Haynes 01-03, Haynes 01-09 and Chilton 01-03) and all look they were copied from each other. Doesn't look like that up dated the 01-09 except for changing the title.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 30 Apr 2012, 08:55 pm
Cool Cruiser
 
Join Date: May 2011
Posts: 228
Default Re: 2008 - 2.4 owners

Aha. It figures. EGR must be on the air box side of the block then maybe buried? I dont see anything leading to it, vacuum lines etc. Really weird
Reply With Quote
  #4 (permalink)  
Old 30 Apr 2012, 09:08 pm
TurboDucky's Avatar
Cool Cruiser
 
Join Date: Mar 2010
Location: Ashland, Ohio
Posts: 461
Default Re: 2008 - 2.4 owners

Quote:
Originally Posted by L2fish View Post
Aha. It figures. EGR must be on the air box side of the block then maybe buried? I dont see anything leading to it, vacuum lines etc. Really weird
If you have a 2008, then you don't have an EGR valve setup.
__________________
2005 Dark Slate Gray Convertible - 2.4 Turbo Lite'ish - Automatic.

2001 PT Cruiser - NA - 5 Speed - Exhaust and CAI Mods - It's alive!!!
Reply With Quote
  #5 (permalink)  
Old 01 May 2012, 03:53 am
Cool Cruiser
 
Join Date: May 2011
Posts: 228
Default Re: 2008 - 2.4 owners

No kidding! No EGR, wow! Those things have been standard items since 1972. Is there no MAP sensor either?
Reply With Quote
  #6 (permalink)  
Old 01 May 2012, 06:07 am
TurboDucky's Avatar
Cool Cruiser
 
Join Date: Mar 2010
Location: Ashland, Ohio
Posts: 461
Default Re: 2008 - 2.4 owners

Should have a MAP sensor. All the ones I've seen are on the back of the intake, towards the passenger side.
__________________
2005 Dark Slate Gray Convertible - 2.4 Turbo Lite'ish - Automatic.

2001 PT Cruiser - NA - 5 Speed - Exhaust and CAI Mods - It's alive!!!
Reply With Quote
  #7 (permalink)  
Old 01 May 2012, 06:48 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: 2008 - 2.4 owners

MAP sensor, on the back edge of the upper manifold.

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #8 (permalink)  
Old 02 May 2012, 04:24 am
Cool Cruiser
 
Join Date: May 2011
Posts: 228
Default Re: 2008 - 2.4 owners

Ok thanks. After re-gappig the plugs now it seems to idle rougher on colder mornings. Gets better as the car warms up. Fuel mileage has dropped. Plugs were grayish white, all even. It seems to be running lean which would be a fuel or manifold leak.
Reply With Quote
  #9 (permalink)  
Old 02 May 2012, 05:41 am
Kawizx9r's Avatar
Senior Cruiser
 
Join Date: Aug 2010
Location: Salinas, CA
Posts: 1,575
Default Re: 2008 - 2.4 owners

If you had a manifold leak, you'd hear it for sure (vacuum leak).

Sorry I can't add more to this.
__________________
Quote:
Originally Posted by Chromenut View Post
Kawi is a friggin genius!
Reply With Quote
  #10 (permalink)  
Old 03 May 2012, 04:26 am
Cool Cruiser
 
Join Date: May 2011
Posts: 228
Default Re: 2008 - 2.4 owners

Crewzin I found the MAP sensor. Geez I blind sometimes
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PT GT atx owners 05PTGT General Turbo Discussions 31 18 Dec 2011 02:14 am
We are now the owners.. morrises General PT Cruiser Discussions 13 16 May 2008 10:37 am
PT owners skeeter1620 General PT Cruiser Discussions 21 01 Feb 2004 03:38 pm
New owners mamamia General PT Cruiser Discussions 4 02 Mar 2003 11:09 am
Gt Owners only turbomangt General PT Cruiser Discussions 9 06 Feb 2003 09:57 am


All times are GMT -5. The time now is 11:31 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors