PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Fuse Box Problems

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 May 2012, 03:19 pm
Fresh Cruiser
 
Join Date: May 2012
Posts: 6
Default Fuse Box Problems

I was test my fuses with a light tester...and I found a pattern in where fuses 1-8, 17-20 do not light up. so as to say row 1 , row 2 and row 4 fuses don't power up. I replaced with new fuses and still do not light up. does anyone know anything about this weird and usual problem?
Reply With Quote
  #2 (permalink)  
Old 13 May 2012, 03:41 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Fuse Box Problems

A little bit more information would be helpful.

What year PT do you have?
Why were you checking the fuses in the first place?
How long have you had the car and what kind of problems are you having that make you check the fuses?
Do you know about the other fuse box?
If THAT many fuses don't work, almost nothing on the car should work. Is that right?
When did this all happen?
Did the car suddenly come to a halt while driving?

Last edited by CREWZIN; 13 May 2012 at 03:46 pm.
Reply With Quote
  #3 (permalink)  
Old 13 May 2012, 03:44 pm
Fresh Cruiser
 
Join Date: May 2012
Posts: 6
Default Re: Fuse Box Problems

Its a 2002. i also checked the smart junction box panel and i had the fusible link 40a blown and 2 15amp mini fuses. i replaced them, and those are fine. its just the fuse panel under the steering column that im confused on
Reply With Quote
  #4 (permalink)  
Old 13 May 2012, 03:51 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Fuse Box Problems

3 fuses in the PDC under the hood and 3 rows of fuses in the interior, all blown. Needless to say you have a major electrical fault. Was the car in an accident or just bought without knowing it's history like maybe it's been in a crash or under water? This happen all at once? Do you own the car or trying to fix it for someone else? doesn't sound like something that just came on all of a sudden.
Reply With Quote
  #5 (permalink)  
Old 13 May 2012, 04:00 pm
Fresh Cruiser
 
Join Date: May 2012
Posts: 6
Default Re: Fuse Box Problems

No i been having the car for a little over a year now...just recently i had a guy to replace the cylinder head because the one it had cracked. overheating problems. but when he put it back together thats what i found. do you think that it might have been that the guy did not disconnect the battery before working and might passed short to ground on the fuse box?
Reply With Quote
  #6 (permalink)  
Old 13 May 2012, 04:05 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Fuse Box Problems

That's one guess. He obviously did something to cause a massive blowout of all those fuses. A lot of electrical tracing has to be done to find out where the major fault is.
Reply With Quote
  #7 (permalink)  
Old 13 May 2012, 04:08 pm
Fresh Cruiser
 
Join Date: May 2012
Posts: 6
Default Re: Fuse Box Problems

have you ever replaced a fuse box panel? and if so...is it complicated to do so? would u recomend replacing the panel?
Reply With Quote
  #8 (permalink)  
Old 13 May 2012, 04:12 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: Fuse Box Problems

Out of my expertise. Never had to replace anything except a fuse. I would imagine you would have to change out not only the fuse box but a good part of the wiring harness ..... and that still wouldn't tell you what caused the massive blowout. That has to be found first before you replace anything.
Reply With Quote
  #9 (permalink)  
Old 13 May 2012, 04:15 pm
Fresh Cruiser
 
Join Date: May 2012
Posts: 6
Default Re: Fuse Box Problems

yeah thats true...tracing out the problem. well thanks anyways
Reply With Quote
  #10 (permalink)  
Old 13 May 2012, 04:30 pm
Banned
 
Join Date: Sep 2009
Location: south of Tampa, Florida
Posts: 3,037
Default Re: Fuse Box Problems

You still haven't told us what your PT will or won't do that led you to do all of this "testing". In short "whats wrong".

Jerry
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
no Fuse problem and not iod fuse ptcarter Tech & Performance Forum 24 09 Jul 2013 03:21 am
HELP with Wiring Fuse 7 (No feed to fuse) No A/C, Electric Windows, Rear fogger??? ptcruisershoreham General PT Cruiser Discussions 3 08 Mar 2011 08:06 pm
Does anyone know where the ECM fuse is? hectormc29 Tech & Performance Forum 0 05 Feb 2011 01:08 pm
No fuse??? Ironman Tech & Performance Forum 0 07 Dec 2009 06:30 pm
no fuse aamlj General PT Cruiser Discussions 3 07 Jul 2007 02:24 pm


All times are GMT -5. The time now is 03:20 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors