PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
short circuit...but where?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 22 May 2012, 06:51 am
Fresh Cruiser
 
Join Date: May 2012
Posts: 2
Default short circuit...but where?

Hi, I have a 2001 PT and while trying to wire wire in manual toggle switch to control my radiator fan (don't ask), I shorted something out.
Facts: with key in on position (or trying to start car)
Won't start
No radio
No dash cluster lights
No power to windows, sun roof, blinkers, windshield washers
BUT, I can control the defrost fan when turing the ignition to on

However, I have head lights, parking lights, 4 way flashers, dome light as normal.

I've checked with ohm meter (or swapped out) all fuses under dash and under hood, relays etc. but all seem to be good. From the wiring diagragm, seems like it should be the 30 AMP fuse under the hood, but even if i take one of the 40 amp fuses and place it in that socket...nothing.
Is there any other fusible link other than the one between he starter and alternator??
I'm no longer worried about fixing the issue with the radiator fan....that I can understand. Thnaks in advacne for any advice
Reply With Quote
  #2 (permalink)  
Old 22 May 2012, 09:07 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: short circuit...but where?

Seems to me, under hood fuse #1 (ignition start) or #13 (ASD) should be the ones to carefully look at.

Reply With Quote
  #3 (permalink)  
Old 23 May 2012, 07:26 am
Fresh Cruiser
 
Join Date: May 2012
Posts: 2
Default Re: short circuit...but where?

Thanks...as it turned out, it was the 30 AMP fuse under the hood in the PDC. Took 5 minutes in the garage to determine that. Strange thing, the fuse tested good with my meter so I never replaced it. UGH...waiting to pick the car up to see how much I owe for that snaffu.
Reply With Quote
  #4 (permalink)  
Old 23 May 2012, 09:39 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,743
Default Re: short circuit...but where?

You mean the No#1 30 Amp (Ignition start)? I took a good guess there, huh?

Sorry that a garage/dealer had to find it, but you said it tested good? Strange.
Reply With Quote
  #5 (permalink)  
Old 23 May 2012, 10:05 am
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: short circuit...but where?

i had this issue out of the blue, but it wasnt a fuse. all lights just went dead while driving down the road one day, turns out it was a fusable link.....ran me $75
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP I caused a short circuit!!!! niel General PT Cruiser Discussions 6 23 Feb 2012 12:53 pm
PCM Knock Sensor Circuit?????? turbonate2003 General Turbo Discussions 11 19 May 2011 06:52 pm
2001 EGR Solenoid control circuit flowerpot Tech & Performance Forum 0 12 Jan 2009 08:11 pm
Cooling circuit Kirby General Turbo Discussions 3 03 Aug 2008 05:49 am
Fog Lamp Circuit SILVERONE Exterior Accessories Forum 8 04 Jan 2004 10:40 pm


All times are GMT -5. The time now is 09:52 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors