PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Poor acceleration, no power up hills

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 17 Jul 2012, 12:19 am
NuYork's Avatar
Fresh Cruiser
 
Join Date: Sep 2008
Location: Now living in Texas
Posts: 43
Default Poor acceleration, no power up hills

2004 Cruiser, having problems with poor acceleration going up hill. Poor throttle response. Idles fine. Sounds like it bogs down, tranny rpms around 4000 before it shifts. Any suggestions?
Reply With Quote
  #2 (permalink)  
Old 17 Jul 2012, 12:34 am
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: Poor acceleration, no power up hills

sounds like what mine was doing 4 weeks ago until the idle went to hell too.

Its not your alternator :-D haha

Check the vacume lines, and your cat. i believe my issue is a clogged cat. has all the symptoms.

Oh and the idle air controler, Throttle position sensor and the EGR :-D
Reply With Quote
  #3 (permalink)  
Old 17 Jul 2012, 03:35 am
JenneK's Avatar
Cool Cruiser
 
Join Date: Jun 2012
Location: Island of Maui
Posts: 275
Default Re: Poor acceleration, no power up hills

How many miles?
Check engine light on?
When did it start with the symptoms?
Still using the same gas station as usual?
When is the last time a "tune up" was done (if mileage dictates)?
__________________
Ken posting about his Jenny's car.

01 w/JBA headers, Borla catback, Airaid intake, lowered, purple with shiny wheels.
Reply With Quote
  #4 (permalink)  
Old 19 Jul 2012, 07:16 pm
NuYork's Avatar
Fresh Cruiser
 
Join Date: Sep 2008
Location: Now living in Texas
Posts: 43
Default Re: Poor acceleration, no power up hills

118,000 miles engine light on and codes P0522 and P0420. I have already given it a tune up and replaced the oil pressure sensor. Issues started before tune up and still continue.
Reply With Quote
  #5 (permalink)  
Old 19 Jul 2012, 07:45 pm
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 27,720
Default Re: Poor acceleration, no power up hills

A clogged CAT will do exactly that, check it out.
__________________
........
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 123,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Cruiser Of The Month (COTM) May, 2015.
Visit My Home Page www.CREWZIN.com
I find it ironic that the colors red, white, and blue stand for freedom until they are flashing behind you.
Reply With Quote
  #6 (permalink)  
Old 19 Jul 2012, 08:13 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,219
Default Re: Poor acceleration, no power up hills

I agree with the clogged cat. I had a Trailblazer before my PT Cruiser and the early models were notorious for clogged cats and their symptoms were identical to what you are describing.
Reply With Quote
  #7 (permalink)  
Old 19 Jul 2012, 08:50 pm
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,782
Default Re: Poor acceleration, no power up hills

Quote:
Originally Posted by Ray_Dockrey View Post
I agree with the clogged cat. I had a Trailblazer before my PT Cruiser and the early models were notorious for clogged cats and their symptoms were identical to what you are describing.
Only thing was the cat wasn't the real problem on most blazers. It was the spider injector unit. Open the exhaust they ran fine. Replace the injector unit and they ran fine with the exhaust on. None of this translates to the Pt though. Your probably right about the cat on this pt.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
  #8 (permalink)  
Old 19 Jul 2012, 10:25 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,219
Default Re: Poor acceleration, no power up hills

Quote:
Originally Posted by Busted_PT View Post
Only thing was the cat wasn't the real problem on most blazers. It was the spider injector unit. Open the exhaust they ran fine. Replace the injector unit and they ran fine with the exhaust on. None of this translates to the Pt though. Your probably right about the cat on this pt.
Wrong vehicle. The Trailblazer had a 4.2 dual cam inline six with variable cam timing or the V-8. They were produced from 2002-2009. They clogged because GM used to small a cat and they overheated and clogged. They fixed the issue in 2004. The reason it translates is because even though different vehicles the symptoms are identical and is a place to start. Trans shifts weird, no power especially up hills, and just a plain dog to drive.
Reply With Quote
  #9 (permalink)  
Old 20 Jul 2012, 02:05 am
JenneK's Avatar
Cool Cruiser
 
Join Date: Jun 2012
Location: Island of Maui
Posts: 275
Default Re: Poor acceleration, no power up hills

Hmmmm... 118K. I would replace the O2 sensor first. It is, afterall, why the P0420 code is coming up.
__________________
Ken posting about his Jenny's car.

01 w/JBA headers, Borla catback, Airaid intake, lowered, purple with shiny wheels.
Reply With Quote
  #10 (permalink)  
Old 20 Jul 2012, 08:23 am
Fresh Cruiser
 
Join Date: Jul 2012
Location: Pennsylvania
Posts: 3
Default Re: Poor acceleration, no power up hills

Can the catalytic converter become clogged without throwing any codes?

My sister's black 01 non-turbo has the exact same symptoms: absolutely no power, even for a non-turbo; "putting" exhaust; poor milage, but no dashboard lights have come on. It only has 77k miles on it too.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Poor Mileage and Low Power... GangstaMobile Tech & Performance Forum 10 19 Mar 2012 07:03 am
misses bad, no power on hills and oil on plugs ashtrae311 Tech & Performance Forum 7 24 Dec 2011 03:33 am
shakey in drive, and on hills SaipanPT Tech & Performance Forum 1 22 Mar 2010 11:12 am
Granada Hills, CA Holiday Parade -- Dec. 4 Basset Hound Western PT Forum 0 23 Nov 2005 11:34 pm
Granada Hills, CA Christmas Parade -- Dec. 7th. Basset Hound Western PT Forum 0 02 Dec 2003 01:25 am


All times are GMT -5. The time now is 08:40 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors