PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
HELP!!!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18 Jul 2012, 09:59 am
Fresh Cruiser
 
Join Date: Jun 2012
Posts: 13
Default HELP!!!

my pt broke down last night. i was taking a friend home from work and the car worked just fine. when i got to her house i turned the car off, when i went to start it up again i got nothing. no lights no clicks, no sounds or light of any kind. i called to get a jump and hooked her up to the battery, got lights and sounds, but no engine start. took the car off the battery and the car went totally dead again. also put anti freeze in the over flow container and it just leaked out onto the ground...any thoughts? am i going to have to donate an arm and a leg for this repair?

thanks for looking and for any responses.
Reply With Quote
  #2 (permalink)  
Old 18 Jul 2012, 10:06 am
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: HELP!!!

the overflow bottle has a drain to prevent overfilling. you can pour water in it for an hour and it will never reach the cap. it'll just pour out onto the ground through the drain tube(that you can't see).

Last edited by rob342; 18 Jul 2012 at 11:23 am.
Reply With Quote
  #3 (permalink)  
Old 18 Jul 2012, 10:48 am
Obsessed Cruiser
 
Join Date: Nov 2007
Location: Mooresville, NC
Posts: 5,325
Default Re: HELP!!!

Did you check your fuses? Did you get any error codes?
Reply With Quote
  #4 (permalink)  
Old 22 Jul 2012, 11:27 am
Fresh Cruiser
 
Join Date: Jun 2012
Posts: 13
Default Re: HELP!!!

didnt get any error codes or dash lights. only did the self test and it showed error 1684, i looked that up and its something like driver 5 line 4....wth? the issue was fixed by a mechanic....bad battery cable and wire. but i did the self test afterward and got the error code.
Reply With Quote
  #5 (permalink)  
Old 22 Jul 2012, 11:56 am
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 27,648
Default Re: HELP!!!

From PT Do-It-Yourself.net:

P1684 does not indicate a problem; it's only a status, which indicates that the PCM memory has been cleared within the last 50 ignition cycles.
__________________
........
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 123,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Cruiser Of The Month (COTM) May, 2015.
Visit My Home Page www.CREWZIN.com
I find it ironic that the colors red, white, and blue stand for freedom until they are flashing behind you.
Reply With Quote
  #6 (permalink)  
Old 22 Jul 2012, 02:58 pm
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: HELP!!!

Starter! :-D

Had this happen on my 99 neon sport.

Overheated. Died. had towed to a buddies, replaced thermo/fluid went to start. NOTHING. No lights, no power, no clicks when i turned the key. Jumped it. Got lights, took off the cables all dead again.

Turns the overheat had popped my Valve Cover gasket, thus leaking oil into the starter which shorted everything and killed it. When i took the starter out it was full of oil. Replaced VCG, put in new starter. Ran like a clock.

Try to jump it from the starter. If it works.......your starter is toast :-D
Reply With Quote
  #7 (permalink)  
Old 22 Jul 2012, 03:28 pm
Fresh Cruiser
 
Join Date: Jul 2012
Posts: 1
Default Re: HELP!!!

Quick question, or I think it may be quick. I have a 2006 PT Cruiser Touring. Was running fine and turned the engine off at a drive thru. Now it will not start. I have power to interior and lights. When you turn the ignition it does a click. Replaced battery and pos cable connector and was told to replace the relay switch. The relay switch I was given does not look anything like the part from the car and am not sure if I pulled the right part even. Where is the relay switch and what does it look like on a 2006 PT touring ed?

Thank you for any assistance.
Reply With Quote
  #8 (permalink)  
Old 22 Jul 2012, 03:29 pm
Senior Cruiser
 
Join Date: May 2012
Posts: 1,354
Default Re: HELP!!!

Quote:
Originally Posted by JPChambers1 View Post
Quick question, or I think it may be quick. I have a 2006 PT Cruiser Touring. Was running fine and turned the engine off at a drive thru. Now it will not start. I have power to interior and lights. When you turn the ignition it does a click. Replaced battery and pos cable connector and was told to replace the relay switch. The relay switch I was given does not look anything like the part from the car and am not sure if I pulled the right part even. Where is the relay switch and what does it look like on a 2006 PT touring ed?

Thank you for any assistance.
You test your starter as well. as well as the ignition switch. Take your stock relay back to the parts store with you so you can match it up to the correct one.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:58 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors