PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
pt troubles

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 20 Jul 2012, 03:52 pm
Fresh Cruiser
 
Join Date: Jul 2012
Posts: 2
Question pt troubles

Hello
I bought a used 05 pt cruiser touring edition non turbo with 100k miles.
After a battery replacement things were going good (other than her gas guzzling)
A couple months later I'm driving to work at 4 in the morning, i get off the freeway and theCEL comes on and it starts hesitating. After visiting this site i learn my pt is in 'limp mode' i did the 'key dance' and pulled error code P0340. So i bought the part from the dealer and replaced it. Reset the codes. Car remained in limp mode. We replaced the spark plugs, spark plug wires, did a full tune up, car remains in limp mode. I have learned so much from this forum and i do love my pt, but what else can i do to pull her out of this?

Please help.
Reply With Quote
  #2 (permalink)  
Old 20 Jul 2012, 06:49 pm
UptownSport's Avatar
Veteran Cruiser
 
Join Date: Jan 2011
Location: 55403
Posts: 3,918
Default Re: pt troubles

Here's from OBD codes
Quote:
Hard starting or no start
Rough running / misfiring
Loss of engine power

Causes

A code P0340 could mean one or more of the following has happened:

a wire or connector in the circuit could be grounded/shorted/broken
the camshaft position sensor may have failed
the PCM may have failed
there exists an open circuit
the crankshaft position sensor may have failed

Possible Solutions

With a P0340 OBD-II trouble code, diagnosis can be tricky at times. Here are some things to try:

Visually inspect all the wiring and connectors in the circuit
Check for continuity in the circuit wiring
Check the operation (voltage) of the camshaft position sensor
Replace the camshaft position sensor as required
Check the crankshaft position circuit as well
Replace circuit wiring and/or connectors as required
Diagnose/replace the PCM as required
Reply With Quote
  #3 (permalink)  
Old 21 Jul 2012, 11:31 am
Fresh Cruiser
 
Join Date: Jul 2012
Posts: 2
Default Re: pt troubles

Thanks I'll try those when i get home and let you know how its running
Reply With Quote
  #4 (permalink)  
Old 21 Jul 2012, 12:06 pm
Cool Cruiser
 
Join Date: Jun 2010
Posts: 252
Talking Re: pt troubles

Why did you post under Stage Turbo Kits?
Reply With Quote
  #5 (permalink)  
Old 21 Jul 2012, 12:23 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,758
Default Re: pt troubles

Quote:
Originally Posted by NightWing View Post
Why did you post under Stage Turbo Kits?

Not there any more.
Reply With Quote
Reply

Tags
limp mode, p0340


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
IAC troubles rob342 General PT Cruiser Discussions 1 16 Jun 2012 01:55 pm
06 troubles Jocko Tech & Performance Forum 4 26 Apr 2012 02:02 pm
Car Troubles PTCMIAH62 General PT Cruiser Discussions 9 07 Sep 2010 11:00 am
New guy... MBC troubles SRT Turbo Performance 3 02 Apr 2010 10:40 am
Lowering Troubles TemporeLegis General PT Cruiser Discussions 1 18 Sep 2007 02:37 pm


All times are GMT -5. The time now is 02:24 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors