PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
2007 problem solved - No turn signals, no wipers, no highbeams, lights on

 
Like Tree1Likes
  • 1 Post By Nameless1

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 28 Jul 2012, 02:30 pm
Fresh Cruiser
 
Join Date: Jul 2012
Location: NC
Posts: 1
Default 2007 problem solved - No turn signals, no wipers, no highbeams, lights on

Since I helped narrow down my problem by reading other posts, I thought'd I'd help someone else out.

We have a 2007 PT Turbo Touring Convertible.
Wife left top down in the rain for less than a minute but it may have been enough to short out the multifunction switch. Next day we had the symptoms below.

Symptoms: No Turn Signals, No Wipers, Low Beams stay on while on, No High Beams.

Note, cruise control was fine. Hazard lights were fine. No problems with any other electrical.

1. I disconnected the battery and pulled every fuse and checked each for continuity with a multimeter.
2. I plugged in my OBD II reader; no errors shown.
3. I did the key-ignition code check; no errors shown.
4. I wiggled cables under the hood and under the steering column.
5. Took car to a reputable dealer.

Fix: The dealer tested electrical and determined it was the turn signal/lights multifunction switch and replaced it.

Cost: $96 for parts and $97 for 1 hour labor and had to leave it overnight to wait for the parts.

Bottom line is I could have replaced the switch myself, but I wasn't sure if it was the TIPM under the hood or which multifunction switch it was (since wipers also didn't work). So I am very glad I didn't fool with it and went straight to the dealer. They were very reasonable.

Good luck!
UptownSport likes this.
__________________
2007 PT Touring Convertible
Reply With Quote
  #2 (permalink)  
Old 28 Jul 2012, 02:59 pm
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 27,641
Default Re: 2007 problem solved - No turn signals, no wipers, no highbeams, lights on

Thanks for getting back to the forum with your explanation.
__________________
........
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 123,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Cruiser Of The Month (COTM) May, 2015.
Visit My Home Page www.CREWZIN.com
I find it ironic that the colors red, white, and blue stand for freedom until they are flashing behind you.
Reply With Quote
  #3 (permalink)  
Old 15 Aug 2013, 07:47 am
Fresh Cruiser
 
Join Date: Jul 2013
Posts: 22
Default Re: 2007 problem solved - No turn signals, no wipers, no highbeams, lights on

Hi... I ran across this thread while trying to fix the exact same issue with my 2007 pt cruiser.... and I seem to be finding two different answers - in terms of the multifunction switches on the 07 models, are there two, or just one? The functions that are not working on my pt encompass two switches, one on each side of the steering column...
Reply With Quote
  #4 (permalink)  
Old 15 Aug 2013, 08:30 am
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 27,641
Default Re: 2007 problem solved - No turn signals, no wipers, no highbeams, lights on

Quote:
Originally Posted by InfamousCruiser View Post
Hi... I ran across this thread while trying to fix the exact same issue with my 2007 pt cruiser.... and I seem to be finding two different answers - in terms of the multifunction switches on the 07 models, are there two, or just one? The functions that are not working on my pt encompass two switches, one on each side of the steering column...

Nameless (first poster) also said his wipers were not working which are on the opposite side of the MFS and replacing the MFS fixed that problem also. So, unless you'd like to take it to the dealer, replacing the MFS sounds like a good bet that it will fix whatever is wrong with yours.

Yes, there are two switches to choose from when buying a new MFS. One with and one without the control for the fog lights.

The WHOLE switch. MFS is on the left.
__________________
........
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 123,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Cruiser Of The Month (COTM) May, 2015.
Visit My Home Page www.CREWZIN.com
I find it ironic that the colors red, white, and blue stand for freedom until they are flashing behind you.
Reply With Quote
  #5 (permalink)  
Old 15 Aug 2013, 08:33 am
Fresh Cruiser
 
Join Date: Jul 2013
Posts: 22
Default Re: 2007 problem solved - No turn signals, no wipers, no highbeams, lights on

Geez, thanks for the quick reply - here's one more question. How difficult is replacing the mfs switch for someone who does not have much car repair experience? I have no problem taking it somewhere if that's what has to be done, but it's something that I think I could do, I could certainly try. Thanks again.
Reply With Quote
  #6 (permalink)  
Old 15 Aug 2013, 09:04 am
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 27,641
Default Re: 2007 problem solved - No turn signals, no wipers, no highbeams, lights on

Here's a thread from our HOW TO section that has a video that may answer all your questions;

**Multifunction Switch How-To Video**

Read the whole thread for more information.
__________________
........
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 123,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Cruiser Of The Month (COTM) May, 2015.
Visit My Home Page www.CREWZIN.com
I find it ironic that the colors red, white, and blue stand for freedom until they are flashing behind you.
Reply With Quote
  #7 (permalink)  
Old 15 Aug 2013, 01:25 pm
sanatanadharma's Avatar
Dedicated Cruiser
 
Join Date: Sep 2010
Location: outside the states of delusion
Posts: 2,613
Default Re: 2007 problem solved - No turn signals, no wipers, no highbeams, lights on

The switch as pictured has two separately replaceable halves, each with a control stalk. The left side stalk, as CREWZIN says, is either with or without fog light control.
I tried to pull up a photo. A Google images or eBay search will further elucidate.


Quote:
Originally Posted by CREWZIN View Post
...
The WHOLE switch. MFS is on the left.
Reply With Quote
  #8 (permalink)  
Old 15 Aug 2013, 07:36 pm
randyincctx's Avatar
Veteran Cruiser
 
Join Date: Jun 2013
Location: Corpus Christi,Tx.
Posts: 3,489
Lightbulb Re: 2007 problem solved - No turn signals, no wipers, no highbeams, lights on

In case photos & written instructions aren't enough;Here's a Youtube video for you:
Also found some fair price on parts.(although most member HIGHLY recommend genuine MOPAR electrical parts!)
http://www.rockauto.com/catalog/x,ca...,parttype,4832
http://www.rockauto.com/catalog/x,ca...,parttype,4856
__________________
2003 PT Cruiser (Base-N/A) Patriot Blue Pearl Purchased @ Police Impound Auction for $1,000.
Aka:~KILLER~

Last edited by randyincctx; 15 Aug 2013 at 07:44 pm. Reason: Added parts links.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
No headlights, turn signals, or wipers. Nathan Tech & Performance Forum 4 21 Dec 2012 01:37 pm
Fuse pops & wipers/ turn signals won't work... owensbigheart Tech & Performance Forum 1 11 Jun 2012 05:00 pm
Windshield wipers, turn signals, interior lighting ibking General PT Cruiser Discussions 0 09 Jun 2012 06:55 pm
Headlight, Wipers, Turn Signal, Accessory Lights greasdawg General PT Cruiser Discussions 4 20 Jul 2011 12:01 pm
No turn signals, wipers, washers for 2006 pt thundert79 General PT Cruiser Discussions 4 13 Dec 2008 08:55 pm


All times are GMT -5. The time now is 09:38 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors