PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Camshaft sensor won't stay sealed

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01 Aug 2012, 12:01 pm
manfred's Avatar
Young Cruiser
 
Join Date: Apr 2012
Location: Oregon
Posts: 84
Angry Camshaft sensor won't stay sealed

This is beginning to piss me off. I replaced the camshaft sensor, magnet and seal (all brand new Mopar parts) about 4 months ago and noticed that the seal started to seep oil about a month or so later. So, I replaced the seal AGAIN (new Mopar part) and guess what? After about a month of driving, the seal is starting to seep yet again! Is this seal just a lousy part, it looks very insubstantial, or is there a better brand seal or a better way to seal the cam sensor that will hold in oil longer than about a month? Unfortunately, when it leaks, it will drip down onto the wire harness over time. Oil's not too great on wire insulation.
__________________


Mighty Manfred, The Wonder Dog PT Cruiser
Reply With Quote
  #2 (permalink)  
Old 01 Aug 2012, 01:26 pm
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 27,720
Default Re: Camshaft sensor won't stay sealed

Take it all out and use a flashlight to see if there's something in the place where the magnet goes that would stop it form sitting correctly.
__________________
........
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 123,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Cruiser Of The Month (COTM) May, 2015.
Visit My Home Page www.CREWZIN.com
I find it ironic that the colors red, white, and blue stand for freedom until they are flashing behind you.
Reply With Quote
  #3 (permalink)  
Old 01 Aug 2012, 02:53 pm
Regular Cruiser
 
Join Date: Oct 2011
Posts: 115
Default Re: Camshaft sensor won't stay sealed

Are you torquing it to the right spec? If you are I would just clean the surfaces good and put some RTV on it and let it set up.

Bob
Reply With Quote
  #4 (permalink)  
Old 01 Aug 2012, 05:03 pm
manfred's Avatar
Young Cruiser
 
Join Date: Apr 2012
Location: Oregon
Posts: 84
Default Re: Camshaft sensor won't stay sealed

Quote:
Originally Posted by CREWZIN View Post
Take it all out and use a flashlight to see if there's something in the place where the magnet goes that would stop it form sitting correctly.
Everything clears and there are no obstructions. The only thing I've noticed is that the new sensor warped slightly in between the bolts when I initially torqued it down, almost like the plastic is not strong enough to evenly compress the seal all the way around. I can almost stick my fingernail into the gap in the middle. Internally, it's not hitting anything. And I did use the proper torque specs from my factory shop manual with a good inch-pound torque wrench. The old OEM sensor didn't have that warp and it looks a little more substantial in construction and reinforcement than the newer OEM part I just bought. Almost like Mopar cheapified it a little in the reinforcing department. The seal itself looks downright puny, not like a good solid ring that would fill the sealing space once it was compressed, but I'm guessing that is because the plastic sensor is not very strong.

I'll probably consider Bob's idea of using sealer with a new seal, although very sparingly, unless of course, that's a no, no. I don't want to get any sealer into the cam bearing.
__________________


Mighty Manfred, The Wonder Dog PT Cruiser
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CrankShaft Sensor/CamShaft Sensor Questions PTMomma Tech & Performance Forum 8 12 Aug 2014 02:43 pm
Camshaft sensor? RedEmma Tech & Performance Forum 3 26 Jun 2012 02:45 pm
Camshaft sensor (again!) ABrown Tech & Performance Forum 21 29 Mar 2012 04:31 pm
Crankcase sensor /Camshaft sensor PigFarmer Tech & Performance Forum 21 20 Mar 2012 08:01 pm
Camshaft Sensor ABrown General PT Cruiser Discussions 2 18 Jun 2008 08:36 am


All times are GMT -5. The time now is 06:51 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors