PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Random dashboard lights and losing power

 
Like Tree1Likes
  • 1 Post By koksianglee

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 Aug 2012, 05:35 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 1
Default Random dashboard lights and losing power

I have a 2006 PT. At random times all the dashboard lights light up and I lose power while driving. First time the dealership replaced the battery, then they said it was the connection to the post. Then replaced the TIPM, then said the TIPM wasn't calibrated. Then new battery went bad, and they said it was the cable to the battery that caused the battery to die, they replaced the battery and I paid for the new cable. Then they said it was another cable (they paid for that one). Then they said the TIPM was bad and replaced it. About 1 week later the dashboard started lighting up again. Very random, it was 400 miles between the last time it happened. Now the dealership says STAR said it either the alternator (which the dealership says is good) or the wiring harness ($1,600 not including labor). At what point do they quit guessing and fix it? I don't mind paying for a repair, but make sure you are fixing the car and NOT guessing at my expense. I can't afford to buy a different car or I would get rid of my car. I really like my PT, but this is crazy!! Can anyone help me??
Reply With Quote
  #2 (permalink)  
Old 23 Aug 2012, 05:51 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: Random dashboard lights and losing power

Sounds like a possible ignition switch issue. Read through this.

Ignition switch
Reply With Quote
  #3 (permalink)  
Old 11 Oct 2012, 11:04 am
Fresh Cruiser
 
Join Date: Jul 2009
Location: Melbourne
Posts: 1
Default Re: Random dashboard lights and losing power

Hi Guys I had a similar issue with my 2005 PT Cruiser been a while been trying to figure out what is going on. Tomorrow I am driving my Cruiser to the service centre to have it check again will ask the guys at the service centre to check out the ignition switch. Hope to have it fixed as soon as possible. Thank for the information. George.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why do my tail lights and dashboard lights only go on when I brake? bodykits Exterior Accessories Forum 1 16 May 2009 07:28 am
Random power loss, glow plug light???? toooldforthis Tech & Performance Forum 2 14 Nov 2008 02:11 pm
Losing power to Gauges snowbirdIN Tech & Performance Forum 1 26 Aug 2008 09:44 pm
Stage1 losing power? desliger Stage Turbo Kits 5 11 Mar 2005 11:40 am
Seem To Be Losing Some Power mich_132003 Turbo Performance 8 28 Aug 2004 05:33 pm


All times are GMT -5. The time now is 03:49 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors