PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Hello everyone!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01 Sep 2012, 09:26 am
Fresh Cruiser
 
Join Date: Sep 2012
Location: Lancaster, CA
Posts: 23
Default Hello everyone!

I was on here reading a discussion but then decided to register so i can't find that post anymore. but anyways, it was a post about an o2 sensor. My 02 Pt Cruiser failed smog due to a PSP sensor (power steering, right?) and it's running to rich (so i bought an 02 sensor) i also read that there are two o2 sensors, mine is bank 1 to rich? Does anyone know which o2 sensor is affecting my car? And also how hard it is to replace both of these items? With the 02 sensor I went the easy route and bought the plug in one, since the other one required splicing wires. If anyone can help me with my issue i would greatly appreciate it!!
Reply With Quote
  #2 (permalink)  
Old 01 Sep 2012, 09:45 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Hello everyone!

Both sensors plug into existing connections so neither should require cutting of any wires. On your fault code, you need the second number of the code. There's only one BANK so the fault code should read "bank 1 sensor 1 (or 2). The 1 would mean UPSTREAM sensor, 2 meaning DOWNSTREAM.

UPstream on top of the exhaust manifold.



DOWNstream by the CAT

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 01 Sep 2012, 11:09 am
Fresh Cruiser
 
Join Date: Sep 2012
Location: Lancaster, CA
Posts: 23
Default Re: Hello everyone!

I looked at the smog paper, they said the codes are P0551 Sensor range/Performance. (this does mean the power steering switch right?)
And P0172 System too rich.

Do you know which one i would need to replace with that second code?

And thank you for your help so far. the diagram is great! I wanted to take it to a mechanic but I've had such bad experience with mechanics on this car

I think i can get my dad to do it i just want to be able to give him all the correct information before he touches anything ( He's a body man, not really a mechanic)
Reply With Quote
  #4 (permalink)  
Old 01 Sep 2012, 11:37 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Hello everyone!

Read this for your P0172 code. More involved that I thought.

error code p0172 ?

The P0551 is the power steering switch. Easy to replace but a messy job.

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 02 Sep 2012, 10:41 am
Fresh Cruiser
 
Join Date: Sep 2012
Location: Lancaster, CA
Posts: 23
Default Re: Hello everyone!

Oh man!

Hmm, I'm wondering if it might be the fuel injectors...i was having an issue with my car sputtering really bad when I tried to start it for awhile, then all of a sudden it didn't want to start at all, so i literally had to floor the gas pedal for it to even start...and i had to leave my foot on the gas pedal for a good while....

and then the problem went away? Idk my car is a mess right now! I've had some problems with it :/


I blew a headgasket on my way back from Texas, cause my water pump went out...and somehow while it was at the mechanic my computer was fried....

and I've had an electrical issue...where it just wouldn't start at all, not even through a jump. We had to pop the clutch to get it going, and then one time i had the door open, with my foot out and it was windy...

and everytime the door would hit my foot, my gauges would go crazy (it actually made my speedometer fly all the way around and i had to unplug my battery to make it go back to normal...) weird huh?

anyways enough ranting....all in all i love my car, and im just worried about how to make it pass smog!





Thank you for all your help....
and the diagrams are great!
Reply With Quote
  #6 (permalink)  
Old 02 Sep 2012, 11:18 am
Busted_PT's Avatar
Obsessed Cruiser
 
Join Date: Jan 2012
Location: Beckley, W.V.
Posts: 13,889
Default Re: Hello everyone!

Welcome from West Virginia! I would go and clean all the battery connections and follow the wires and clean those connections also. That requires taking the cables lose were ever they are bolted. The batter may be a bit tired and can cause some weird electrical issues. Then we can see what's left after that.
__________________

03 Dream stock___________________________ 04 Touring turbo lite stock_________ 02 Touring stock_____________________ The "Three Amigos"
__________________________________________________ __________________________________________________ ___________Performance, Body and Service, OEM

This Is my project page.
http://www.ptcruiserlinks.com/forum/...oject-1-a.html

This is a great read from one of our own! Badglas
badglas.blogspot.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:43 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors