PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Tech & Performance Forum

PT Cruiser Forum

Advertisements
Right front turn signal not working

 
Like Tree1Likes
  • 1 Post By soonercruiser

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Sep 2012, 07:30 pm
Fresh Cruiser
 
Join Date: Jan 2011
Location: Central Illinois
Posts: 2
Default Right front turn signal not working

Right front turn signal/parking light quit working. New bulb did not help. I used a voltmeter to determine 12 volts are present at the two pins for parking lights and turn signal however there is no ground present on pin three. I checked the left/drivers side and there is a good ground present on pin three and of course this side functions as it should. Any suggestions? Should I just try to run a new ground wire to the connector? By the way this is 2006 PT.
Reply With Quote
  #2 (permalink)  
Old 14 Sep 2012, 09:11 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: Right front turn signal not working

Chances are its the TIPM. You can try unhooking the battery for 15-20 minutes and see if it resets. If not you will have to take it to the dealer and see if resetting or updating fixes it. The TIPM monitors the entire electrical system using the Canbus system which thy started using in 2006. If it detects an issue it shuts down that circuit.

The problem is it won't reset after the issue is resolved. They had issues with it on the 2006's. Be forewarned that if they say it needs to be replaced it is very expensive. You can do a search for TIPM for more info.
Reply With Quote
  #3 (permalink)  
Old 14 Sep 2012, 10:22 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,770
Talking Re: Right front turn signal not working

I consulted NASCAR.
They said....."turn left"!

(sorry I'm no help.)
podo2000 likes this.
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
  #4 (permalink)  
Old 15 Sep 2012, 04:26 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: Right front turn signal not working

turn on the turn signal and then when you install the bulb, wiggle it in it's connector (in your hand, not installed). my rear bulb was not working and the bulb socket had a shady/intermittent connection. it would work when i tweaked the bulb and then quit when i'd let go. i bent the brass out in the bulb socket so it connects better and it's been fine ever since. careful though, the brass is brittle.

free and easy to try.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield Wipers Turn On With Turn Signal or Bump... NewPTCruiserInPA General PT Cruiser Discussions 8 17 Dec 2013 09:10 am
blue turn signal bulbs that turn orange when in us Capt Kidd General PT Cruiser Discussions 1 04 Jun 2004 10:10 pm
Turn signal gonzomania Exterior Accessories Forum 12 30 Mar 2004 08:53 am
Help removing front turn signal reflector. GT_Firebreather Exterior Accessories Forum 7 28 Jul 2003 02:14 pm


All times are GMT -5. The time now is 06:09 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors